Download

Lidar Point Cloud Plugin Blueprint-Function "not implemented"

Hey guys,

I have a problem regarding the Lidar Point Cloud Plugin.

There seems to be an issue with the function definitions regarding the class “ULidarPointCloudBlueprintLibrary”.

When I try to call the function “CreatePointCloudFromData” (or the blueprint display name: “Create Lidar Point Cloud From Data”), and I run the Program, I do not get the expected results.

So I tried adding a breakpoint on the blueprint node, which in turn revealed a little alert box (see screenshot), which says “not implemented”

After looking through the sources with Visual Studio, the compiler shows a warning in the LidarPointCloud.h at numerous function declarations, all of which are static and not implemented inside the header file (there are some short functions which are implemented inside the header file and are not marked by the compiler).
So I looked up the functions in the LidarPointCloud.cpp and they seem to be defined.

Does anyone know, why the compiler does not seem to find the function definitions, and how to fix my issue?

Thanks!