Download

License Agreement Build Issue

Hi,

I have problem with license agreement issue, which has been asked in AnswerHub here: https://answers.unrealengine.com/que…e-license.html

The solutions provided there are deleting the android-sdk-license file found in NVPACK/android-sdk-windows/license, disable gradle and use ant, or point the android sdk to the original or non-NVPACK one (the one bundled with Android Studio).

I’ve tried all the solutions, and pointing the SDK to the original seems working to me. However, I fear that this brings issue as it doesn’t use the default NVPACK one. Disable Gradle also works, but if I recall, in UE 4.18, it is expected to use Gradle as default.

But my question is, isn’t this issue shouldn’t happen after I press the “Accept SDK License” button? Or is there something I missed?

I’ve just made clean Windows 10 installation. I installed UE 4.18 and NVPACK 1R6u1. Then clicked “Accept SDK License” and it works… So it looks like it’s not a general problem. Maybe try to reinstall NVPACK? You shouldn’t disable Gradle because ANT is deprecated.

We uninstalled NVPACK and reinstalled everything from ue4 extras folder in 4.18

I’ve tried a fresh reinstall of NVPACK and the UE 4.18 as well many times, but didn’t work. I forgot to tell this one is built from the source, maybe there’s something related to it?

I didn’t do clean install though, mine was an upgrade from 7 to 10, I’m not sure how this relates but worth to try.

Disabling the Gradle was just for testing to see if it works just fine and to narrow the issue. As my current solution, though not solving this issue, I’m just pointing the SDK to the one from Android Studio for now.