Lib stdc++ in 4.25 (Linux)

HI !

I would like to understand how can I add the library “stdc++” in the version 4.25 …

I switch my project in 4.22 to 4.25 , but actually I have a problem with the Library [Log][2] when I try to build for Linux

If someone can help me , would be cool .
Thanks anyway

Take a look at this answer and if possible avoid using stdc++ for legal reasons.

If that’s not an option, then I would try doing what the build log suggests. Either:

Move the “stdc++” dependency specifier to the PublicSystemLibraryPaths instead of the PublicAdditionalLibraries,


Provide a fully qualified path to the library on your system which you can get with locate libstdc++.a for static library or locate for dynamic. But be careful if the build is done on different or multiple machines because the path might be different there.

Hope this helps.

thank you for you answer !

To be honest I already Check This Answer :
I don’t understanded what the environment variable was . And where did I have to call It
I’m not the one who put the library on the project , so I’m not familiar with it , but when I check the Dir “ThirdPartyLibs” , I don’t see the “stdc++” . Don’t know if its normal or maybe It’s just with the Toolchain Here , with the -v13 , just the “PublicSystemLibraryPaths” make the work ! or i’m wrong ^^

I tried to do like this exemple Here , but nothing . All this exemples talk about Environment Variable to set . But Are they talking about the same ?

And to end , I tried like the build logs suggest but I had this Log

Anyway , thank you again for you time