LevelSequence on StreamingLevel

UE4.15P3 Mac

I have some issue/bug with type of actor, LevelSequence in LevelStreaming mode. Specially in hidden (not yet loaded) sublevels.

Reproduce of bug:

  1. Create new project based on “3rd person template”.
  2. Choose “StreamingLevelPersistence” mode for streaming levels
  3. One (existing) level already is “Persistent level” and create additional 2 sub levels. And list in “LevelEditor” look like:


*** Level1

*** Level2

  1. On PersistentLevel create “StreamVolume” for Level1 and assign to it in properties.
  2. Make active Level1. Create new level sequence asset “LevelSequence” (LSA in short) and put in Level1. That LSA has track with own animated camera and has AutoPlay=1 in it settings as well (I made it specially for autoplay LSA only on level where that LSA placed).

Initially Level1 and Level2 unloaded. And at start of game they both invisible and unloaded. When game started view changed to LSA camera view automatically and that LSA not played (PlayerController works but camera changed to sequencer camera).

If LSA put on PresistentLevel and start game then LSA plays automatically (from same view) and after camera changed to player camera.

So “LevelSequence” with AutoPlay=1 works incorrectly on streaming levels (change camera view and freeze).

Resolve method right now:
That bug possible to come over in another way - just uncheck AutoPlay=0 and control sequences manually in BP. But its need to do for each level (every BP).

Question: Why that LSA activated (change view) on start and freeze camera view ? I think that LevelSequenceActor must be unloaded as well as Level1. Or that type of actor is “Special” or ignores level streaming mode?


Hi ,

I’ve set this up in my sample project (which is based on the Third Person Template), but I am unable to reproduce it. The Sequence only plays when I load the level and the camera remains on the Third Person Character.

You wouldn’t happen to be trying to manipulate the Third Person Camera, would you?

Character is moving and full controllable but view looks by camera from sequencer.
Warning: Sequencer actor is hidden bcoz it on unloaded level. That level not yet loaded by “streaming level volume”. So sequence actor doesn’t plays and its ok , but why the view switched to sequence’s camera?

I can to create the small simple project sample and post here for download.

That would be great if you could post a sample project. I think there’s probably something crucial that we’re doing differently.

Hey ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.