[LevelSequence] Current Audio Clip keeps playing in loop and with an offset if Play Rate is reduced

In an old project using matinee I lerped the play rate of a matinee down to zero and the currently playing audio clip would keep playing only until it finished.

In 4.14.1 I’m trying to do the same thing in a LevelSequence, but it seems that whenever I change the play rate to zero or close enough (0.001), the sound clip keeps playing BUT when it ends it keeps playing over and over again, and not even the whole of it, just a part of it.

I suspect that it works like that: When reducing the play rate and an audio clip starts, it plays and ends normally, but from the perspective of the sequencer, the actual audio clip will still exist at the current time location since time is moving slower, so it starts playing again, but with a time offset equal to the currently elapsed sequencer time.

Hey kgerontis,

I’m having trouble reproducing this on my end. Can you provide some screenshots or send an example project? You can PM me a download link on the forums.

-Matt W.

I’m going back to the office on Tuesday, so then I will try to create a project isolating the issue and send it, maybe with a capture of the issue as well.

I’m marking this as resolved for tracking purposes until we can continue. Respond here to re-open the issue.

Hello, I made a sample project in which I placed a level with a level sequence which includes some spoken audio and I changed the play rate in blueprint to 0.2 . You can listen to the result in the included .mp3 file, you can hear the audio looping from a different start point each time.

Download file

Hey kgerontis,

I have reproduced this issue and logged UE-40095. You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

-Matt W.

Great, thanks. One more thing, I checked with a sound cue instead of a wave this time and the offset still occurs, contrary to what the issue Description above states. Also, the expected behavior would vary, for example if you’re used to Matinee, you expect no change in the audio pitch, you just expect the sound to play one-off.

ps. Happy new year!

I’ve added an internal note about the expected behavior. We aren’t planning everything to behave the same as matinee, but this probably should.

I also added a suggestion to have an “Ignore Play Rate” option for sound clips in sequencer.

Also happy new year!

Just ran into this in 4.17. Essentially breaks any sequence with audio that uses a play rate modifier.