Download

Levels not showing in simulate / game mode

Hi,

So I started bringing in my Arch viz project bit by bit into UE. and as my project is big, as per the advice I used levels. as in the pic

I made a new default level

went to window -->level and made another level

made it current

placed my models on it.

built the lighting and when i go to play or simulate, my new level hides and only the sky box in persistent level is showing.

ue1level2.jpg

when hit simulate

1957fb885ae4c1544ebfcfa7c87896c877c5a0e9.jpeg

Hi AvengerXP

Is there any chance you camera is just jumping to a different spot where your scene objects aren’t visible?

Hi AvengerXP,

There are two options when you create levels.

  1. Load with Blueprint (default setting) and indicated by the blue dot beside the level name
  2. Always loaded.

You can set these by selecting the Level in the Levels window and right clicking and selecting “Change Streaming Method.”

When you hit Play/Simulate these are disappearing because it is set to load with blueprints.

If you need to load with Blueprints let me know and I can setup an example to help. :slight_smile:

Hi Tim,

Well I wanted to load the 3 buildings separately to 3 levels, because I could bake each building separately and fine tune settings, but once everything is figured all the buildings to show. I will try the change streaming method for now.

Whats your advice on this?

If you just want to build the light for each independently that’s fine. You can adjust the visibility of each level you want to build for accordingly. However, if you hit play it’s going to load all the levels based on whether it’s set to Blueprint or always loaded.

how do u change any of this in 4.14? When i right click there are no options for changing any streaming methods.