Level transform ignores y-coordinate

I want to create landscape tiles in a circular fashion around my player character.
An online tutorial explained how to do this in a square shape and it worked pretty well.
Though when I switch out the code for generating the coordinates less than half the tiles are created.

This is the current state of my code.
The disconnected part in the “old”-comment is from the tutorial, which creates coordinates in a square shape.
The part in the “new”-comment creates coordinates in a circle shape.

This is how it looks like when I simulate.
13 transformations are printed on screen each detailing its supposed coordinates, though only 5 tiles are created.
There doesn’t seem to be a problem with generating the coordinates.

Any idea what’s causing the problem?

Well, seems like I’ve found the problem.
The Create Instance node doesn’t seem to like dots in its unique instance name.
Once I cast the float values to integer before giving them to the Append string node it worked just fine.