Level streaming interfering with Nav mesh - Optimization help

Hi all,

I have hit an issue. In my current level I have separated into sub levels for different sections of structures and AI.

My current example is there is a mission to attack a fort. I currently have the friendly and enemy actors spawned in the world and placed in a sub level which is set to stream via blueprint. I have tried level streaming volume and manual load level stream but when I used this approach, the AI no longer move.

When I set the level to always loaded, they pick up the nav mesh and move perfectly fine.

I have done searching and found a couple of solutions, placing a nav mesh in the sub level and persistent level - This doesn’t work unless I have to make sure they don’t overlap?

Having only persistent nav mesh and set the recast actor to dynamic. This is very expensive and the AI jitter and move around in a very strange way

Does anyone have any suggestions on the best way to handle performance with this? Only other solution I can think of is spawning in the actors for the fort attack when the player is near to the location, but that would cause the immediate performance drop (there aren’t tonnes of AI but around 50ish in this particular battle)

I have also been looking into set hidden/disable tick/disable animation etc, but was wondering if there are any fixes around the nav mesh and level streaming first before exploring spawning in the actors and manually disabling the AI.