Download

Level Sequence animation doesn't play in game

I have an actor in my scene which is just a few sprites and text renderers and looks like this:

https://answers.unrealengine.com/storage/temp/294074-tmp.png

…and I want to have it wiggle a bit to the sides by its rotation. Thus, I created a Level Sequence with a few simple rotation keyframes:

https://answers.unrealengine.com/storage/temp/294075-tmp.png

But even though it all works great when clicking Play in the Level Sequence window, it does not work at all in game. I have auto play on (tried connecting Play BP to Event Begin Play too but it makes no difference) and Loop set to Loop Indefinitely but to no avail. The Scene Root of my actor is set to Movable so it shouldn’t pose a problem. I’ve tried doing this with Matinee too, but the effect is the same (ie. lack of thereof).
I’ve tried doing the very same thing with a primitive cube in the scene and a new Level Sequence and it worked so I have no idea what may be blocking the movement here… Any help would be greatly appreciated :frowning:

I’ve tried also making all the child components Movable but still to no avail :frowning:

It’s been awhile since I used this but their’s a ue4 video series on this. Double check that.

Yeah as I said, the exact same kind of sequence works with a primitive Cube actor so wrong wiring of the sequence won’t be the culprit :confused: