Level renders black/grey on Android?

Hello all,

I have a Samsung Galaxy Note 3 (I think this is almost identical to Galaxy S4) and I am able to build the sample content (except Strategy game) with no problems on my Android phone.
However, I have tried to create two different custom basic levels and the result is a black/very dark grey result on my phone. It’s as if the lighting is not rendering correctly.

On the most basic level I have one static light. In the editor it seems that perhaps something is not right as when building the lighting is complete the scene looks correct (with static shadows etc) but as soon as you move the camera or click any button in the editor, the shadows disappear and a more broad lighting result is displayed.

Has anyone else had this problem?

I also have the galaxy note 3 and found the same problem. Basically the entire screen would just be a dark grey and all I could see were the input controls (virtual thumb sticks). Found that setting MobileHDR to false resolved the issue. Give that a go, it should at least get things running for you (without all the nice visuals)

Another good way too fix this is make sure you run it on the UE virtual mobile. It basically changes it all to mobile looks. That way when you do get ready for your phone you already have to fully setup for the porting.

The odd thing is that the example content provided by Epic renders just fine on the Galaxy Note 3, and the HDR option is selected.

Can someone from Epic comment on this?

Maybe check the example that does work and check the DefaultEngine config file in the project. See if “r.MobileHDR” is set to false within there? I am still learning myself and came across this (is actually how I accidentally discovered it only rendered correctly when that was set to false). Unfortunately I cannot confirm myself right now if the examples do have that set or not. (at work).

The Galaxy Note 3 (Snapdragon 800) is a better device than the Galaxy S4 (Snapdragon 600). Both of those devices supports HDR. I don’t have the source in front of me at the moment, but check AndroidProperties in the C++ source code and check that it returns TRUE for the supports-distance-field-shadows member function. Otherwise everything will always be in full shadow.

Another idea is to toggle off all postprocess effects by typing “show postprocess” as a console command, to see if the issue is with one of those effects, or if it has something to do with lighting.

How can you toggle console commands on Android?

I used blueprint to toggle the post processing on android. Did not fix the issue for me.

A 4-finger tap will bring up a console window.

Thanks. Toggling post process did not help with this problem.

Do you have any thoughts on what problem could be and how to resolve?

Not sure if it’s related to this “bug” but I had also experienced some weird graphic glitches. My level would look fine on pc/mobile preview but on the device itself it would be very dark and some areas wouldn’t get any light at all.
Then I changed my directional light from stationary to static and now it is properly lit but I lost all my specular details, which is a shame. Is there anyway to fix this?

@DRungelrath, that sounds like the bug Niklas Smedberg mentioned. It will be fixed in the next release but if you are compiling the engine yourself you can fix it by modifying FAndroidPlatformProperties::SupportsDistanceFieldShadows() to return true.