Download

Level open fails " FName's 1023 max length exceeded. Got 1024 characters excluding null-terminator"

I spent about a weeks worth of time on designing my level and all of a sudden it refuses to open with the error "Assertion failed: false [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Core/Private/UObject/UnrealNames.cpp] [Line: 1824] FName’s 1023 max length exceeded. Got 1024 characters excluding null-terminator. "

I have no clue what this error is about, as I haven’t changed any code. I tried transferring the assets to a new project and opening the level in the new project but I get the same error.

Can anyone give guidance how to fix this or at least extract the level information so I don’t have to spend time redesigning it from scratch again

i got the same error: Assertion failed: false [File: D :/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Core/Private/UObject/UnrealNames.cpp] [Line: 1824]
FName’s 1023 max length exceeded. Got 1027 characters excluding null-terminator.

Please anyone can give us the solution?

Some Object’s FNAME is apparently longer than 1023. This could be the path of the object, or some other internal string. You can try and nuke your intermediate folder and see if it magically fixes itself - unless you can think of some object you just added which has some long path name.

Had the same issue. Thought file was corrupted, but no. It means that some object or actor that was implemented had a really long path name.

You can try to enable long filenames for example, I didnt try it but here is some documentation: https://docs.unrealengine.com/en-US/…_22/index.html
Search for “Support for long filenames”.

What worked for me was to simply move the whole project folder closer to the root, like your Desktop or Documents folder so that the paths of the files automatically become shorter.

If this does not fix it, I can suggest to delete or replace new files/objects that you may have added last to your project so you can figure out which item in particularly is causing the problem.

And how i can delete objects from my map WITHOUT opening the map? (I have the same issue)

Murdering the intermediate folder fixed it for me. Tried forcing the paths shorter but didn’t seem to help.