Level not switching when packaged

Hello, I have found an issue with my project. I currently have a Login level, and a Game Level, both are fully BP based.

In the editor (including standalone) I can switch between levels just fine. But when packaged, the screen flicks black for a second, but then reloads the login level again - I am switching level using the ‘open level’ node, if that is relevant.

I have added both levels to the packaging list (picture below),

Is there something I am missing?

Thanks for your time.


I have a few questions for you:

  • Could you please provide me with the logs from your device when you’re trying to switch levels?
  • Have you been able to replicate this on newly created project?
  • What about in a different version of the engine?
  • Would you mind providing me screenshots of your blueprints you’re using to switch between levels?


Hello ,

Thanks for getting in touch,

  • It is a windows build, where would these logs be?
  • I just created a fresh shooter template project, but it worked fine…So it must be something I have setup wrong I suppose.
  • I don’t currently have any other versions downloaded to test with.
  • Certainly, I will link some pictures of the BP below - originally it was being called through the gamemode, but to simplify things I have added a new OpenLevel to the player controller (as done on the shooter test) and I am still getting the same issue.

Does the location of the map within the content folders matter?

Thanks for your help!

From the original image you posted, try selecting "Cook everything in the project content directory (ignore list of maps below) and let us know if it packages correctly/

Hi , I have tried that now. Same issue though unfortunately.

I actually have a suspicion now that the level may be changing just fine, but the GameMode is not overriding when the level is opened (My game level is empty as it is all spawned procedurally, starting from the game mode. So my game level is loading, but using my login systems GameMode, which is spawning the login system and making it look like I am still on the login level. )

Is there something I have to do to allow gamemodes to change?

Actually, this does not seem to be the case. I set different backgrounds for the login level and the Game level, and during the flash where the widgets are deleted I can clearly see it is still on the login level.

I’m having trouble determining the issue from your descriptions alone. Can you send me a copy of your project in a zip file in a private message on our [][1]?


Hi GreyDesigns,

Since we have not heard back from you in a while, I am closing this post for tracking purposes. However, if you are still experiencing difficulty changing levels, please send the requested project via private message on our so we can get a closer look and better understanding of what could be causing this issue.




Im having a similar problem. I am using UE4.9.
Usually my game launches fine for when I am testing levels on my android device.
I tried to package the game last night, however when I checked my the game file on my phone only the 1st level/main menu was playable.
When I pressed the play buttons, the main menu/level would just reload itself.
Now my packaging is failing every time.
A few times after the package failed the editor would crash (this does not happen every time I attempt to package)

I have an out put log attached for the failed packaging but for some reason answer hub will not let me attach it. I have the log saved in a word document.

Please help.

Please send the log and/or the project (zipped) in a private message to me on our [Forum].[1]


Hi ,

In your logs, if you see an error stating “Automation Tool Unable to Run…” and there is an error loading an asset, do a search in the log for “Warning Error Summary.” The errors listed first are what is causing it to fail.

In your case, it lead me to your “AquaGUI” blueprint which has a lot of errors preventing it from compiling.

Hi ,
Thank you so much for responding quickly to my request.
This information is very helpful, as far as this project and understanding logs better in general.

However, Im a little confused about the “cant find function” phrase in these logs because:

  1. many of the items listed in the log aren’t directly being used in my game, they are simply part of the AquaGUI pack from which I am using other assets.
    Also, there on only a couple assets from that pack to which I have connected any “functions”.
  2. Would you suggest reloading and replacing all the assets associated with the AquaGUI pack
    OR process of elimination to see which specific game function is not being found?

Since these compile errors are associated with assets that I am not using, I am a little lost as to why there would be a compile error during packaging.
My only thought is that, I might have deleted parts of the AquaGUI that I was not using in order to save space. Maybe the engine still needs some of those unused assets to process correctly.

Thanks in advance.

Did you open the the “AquaGUI” Blueprint, correct the following errors, and retry?

This is what I see in the “AquaGUI” Blueprint without having made any changes to your project and is likely the cause of the error you are seeing:

Hey ,

Thank you very much. I was able to get the game to package properly. this was a great help.

My other question is about Travel Failures. When playing in editor or on mobile device I am getting a “Travel Failure; Invalid url” when I start the game from the main menu level. If I start the game from level select widget there are no travel failures.
Here is the log:
Info Play in editor start time for /Game/Maps/UEDPIE_0_Main_Menu_map 0.023
Warning TravelFailure: InvalidURL, Reason for Failure: ‘Invalid URL: /Game/Maps/Main_Menu_map’. Shutting down PIE.
Warning TravelFailure: ClientTravelFailure, Reason for Failure: ‘Invalid URL: /Game/Maps/Main_Menu_map’. Shutting down PIE.

I imagine I must have missed something in the main menu level or in the project settings.
Where exactly should I be looking?


There could be a variety of things causing this, but given your project, I think the solution posted by paradoc here will likely solve it in your case:

[OpenLevel Travel Failure: Invalid URL - Programming & Scripting - Epic Developer Community Forums][1]

If it does not, please do a search for “Travel Failure; Invalid url” and see if one of the results resolves your issue. If they do not, please start a new AnswerHub post for this specific question as this thread is getting overly long and a little off topic from the original posted question.


OpenLevel Travel Failure: Invalid URL - Programming & Scripting - Epic Developer Community Forums

you have a been a great help.
I will check around the answer hub for more info.

I found the solution to my travel failure;
at some point I changed the name of the level but did not reset the new level name in the OpenLevel Node.
the names were almost identical. didn’t notice until now.

once again,
thanks for the help

Glad to help and thanks for posting your resolution as it may help someone with a similar issue in the future.