Level not loading BP project

Hi folks!

Ran out of ideas to try so reaching out to the community.

I have a game I want to target for mobile and everything was working fine but after a last deployment to my mobile my level doesn’t open anymore.

Everything works fine in the preview and mobile preview but nothing happens on Android. Ive checked 2 devices and got the same result.

I checked the packaged maps as I know that is one reason this could happen and it looks fine.

What other things can cause a level to just not load.

I did the debugging on the device with the android but I don’t see any failure output. I do see feedback when I tap the button that causes the open level action so that part is working.

I’ve had heaps of changes since the previous ‘test run’ deployment on my mobile so don’t really want to undo all that to try and see if I can spot what broke it for mobile. :frowning:
the majority of the changes were refactoring so no major new things added and as mentioned the pc preview run works just fine.

In case anyone else has a similar issue, or for the future self.

Part of refactoring consisted on moving the Custom GameInstance BP class to a different folder. Doing this updated the \Config\DefaultEngine.ini location but did not update the copy located in the android build folder, hence when android tried to load the custom gameinstance it defaulted to the engine one which caused an issue on casting and so the OpenLevel function was never called.

Because the project DefaultEngine.ini got updated running from Unreal Editor worked fine.