Level load working correctly in editor preview but not on iOS device

I am having an issue with going from one map to another, but only on the iOS device itself. I have a simple UMG menu setup, where it loads a couple of buttons. I hit a button to load level one, and the level loads fine. I hit a button in the new level to go back to the main menu, and it works fine in editor / game preview, but not when I launch on iOS (8.1, iPhone 5s) - it just reloads the same level I am on.

Any suggestions as to why it would work fine when playing in editor / mobile preview but not on the device itself? Both load fine, as I can go from menu to level, but just not back from level to menu.

I can post screenshots but it’s a very basic onButtonClicked → open level.

Hello Doug,

I was unable to reproduce this on the device. I have a few of quick questions for you. These will help narrow down the issues that you may be experiencing.

Quick questions:

  1. What version of the engine are you using?
  2. Can you provide a screen shot of the blueprints that are directly involved with the issue?
  3. Can you reproduce this issue with a clean project?

Thanks for your reply Rudy, I am on 4.5.1 (launcher) and have just tried a few more tests - I started a new project and created 3 new levels, each with a UMG widget - Level 1 links to 2, Level 2 to 3 and Level 3 back to 1 with a button on each. Again, in editor this works as expected (the next map is loaded on button press) but not so on mobile.

What I have now noticed is that on device whenever I call Open Level the default map from the project settings is loaded. So whenever I call any Open Level at all, it ignores the level I am asking it to open and just opens the default map - this indicates to me that perhaps it cannot find that level? Are all maps bundled with an iOS deploy by default?

Hello Doug,

I have a couple of quick question for you. How many buttons are you adding to each level? Is it just one button?

In the above example (the new test project) just one button on each level. In my main project there are 2 or 3 in the main menu then just 1 in another level. Note that the above is very basic, in my main project I am hiding Viewports before opening new levels.

Thanks, Doug

Hello Doug,

Just to cover our bases, could you run a print string to all of your button and have them all say different things. This will help make sure that the widgets are being swapped out correctly.

Sure, after each map load? The below screen shots show the Level BP and UMG BP for the first level - levels 2 and 3 are exactly the same (except for loading different levels in each).

The screenshot from the preview is after I have clicked three times and therefore gone around in a loop back to the first map - as before level 1 loads level 2, 2 loads 3 and 3 loads 1 again. Each prints either level 1 loaded, 2 or 3. Still working in editor and not on iOS!

Thanks again for your help.

Hello Doug,

In light of this new information I have another question for you. I had a thought when you said that it just keeps loading the default level. I thought that it may not be loading all of the levels up on to the mobile device and after rereading the all the posts I saw that this was a question that you had already asked and that I missed. In short could you tell me what method/program(s) you are using to load up your game onto the mobile device?

Problem solved - I was launching from the Play > On iOS toolbar button, which I guess only transfers the current level opened in the editor and the default level specified in project settings? When I go to file > package for iOS then install the ipa through iTunes it works on my iPhone as expected. Is this the only way to test multiple map loads on device?

What threw me off was that if I use ‘play on device’ to open the level I was currently on in editor (say a menu) then try to reload said menu from within that menu, the only thing that would open would be the default map.

Thanks again for your help.

I have same problem , i build package , (also try with launcher to check maps - all works one by one).
But still cant open any level on device even after package and deploy with itunes.
I have some strange zoom on button click , after 2 seconds and touch end zoom is back to normal .
My project is based on c++ and blueprint . I make builds from xcode for make sure.
Not important : Buttons position is also moved to left but labels text are on middle
(s. on my bad en).

Maybe , i need to delete manually some folders ?!

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What engine version are you using?
  2. Can you reproduce this issue in a clean project?
  3. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  4. Could you provide screen shots of any blueprints that may be involved with this issue?
  5. What is the exact device that you are using when this issue occurs?
  6. What is the exact OS version that is being run on the device?

Sorry it is just adding map in package tab. For desktop and android is no need for this (just make package ). For iOS we need to to do this (enter just name like start.umap or use browse to the file ) . I get after that a lot of message like ’ external resource …’ , but after builds everything is fine .
Direct me if somebody knows about moving in HUD :wink:

Hello goldenspiral,

Thank you for the additional information however, I will need you to answer the other questions that were asked. This information will help me narrow down what issue it is that you are experiencing.

Hello goldenspiral,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

All platforms works fine except iOS device (mini ipad , ios 8.3). My UE 4.9 .

I use buttons on canvas and also buttons with two vertical controls . On ios device simple screen is 3/4 of normal (editor view) screen.I must manual moving control , I wanna post some example to marketplace . This is sure problem. I try by blue print to move with Transform function but also result is bad (cutting buttons) Thanks for forum and always fast response !

Would it be possible for you to provide your project so that I could take a closer look at your issue? Could you also provide a detailed set of steps to reproduce this issue in the project that is sent?

Please i need private messsage ,
zlatnaspirala@gmail.com , give me email or other way to do that

“private message to me on the forums” Where is the options for that?
I dont see your email also on Video Tutorial on How to use Texture Masks, and embed them in an Alpha Channel - Community & Industry Discussion - Unreal Engine Forums

If you would like to provide the project privately, you can do so by sending it via drop box or google drive using a private message to me on the forums.

You will need to go to the forums (forums.unrealengine.com) and click private messages (Picture for reference) From there you will need to Send me a private message (Rudy.Triplett). I hope that this information helps.