Level load errors after cloning

I primarily work off an external HDD but decided to move one of my projects onto internal drive in order to gain the read/write boost (external is only 10MB/s). Firstly I just copied the project folder over and tried to launch it and then I tried cloning it onto the local drive and launching the clone.

In both instances the same results occurs. The project is based off the Realistic Rendering example from the Marketplace and when opened the default level from the project opens no problem, however when I try to go to File > Open Level and open either the level I created or one of the other levels that came bundled in that project I get the following error.

Failed to load map F:/Level Design (UE4)/Concept_Design_One/ConceptDesignOne/Content/Maps/Concept_Design_One.umap

File is not in any of the following content folders:

C:/Program Files/Unreal Engine/4.4/Engine/Content/
C:/Program Files/Unreal Engine/4.4/Engine/Plugins/Experimental/Paper2D/Content/

The file does exist but is in the folder C:/UE4/ConceptDesignOne2/Content/maps which is where the file is in the original copy of the project and it works just fine. Also strangely the level file I tried to open was from the project copy on the C:/ drive but the error references the F:/ drive (my external).

I haven’t tried moving the map file from the maps folder to the Content folder but I will try this later when I log back on. Even if that does solve the problem why is this happening. Surely when I clone the project I should have to then move the level files around to make it work.

The project caches the map file location as an absolute rather than relative path. If you look at the error, it’s trying to open the map file off your external drive, and complaining that the map you’re trying to load is no longer in the current content folder.

A number of my students have encountered this error before, if you look carefully at the full folder path when you do file-> Open Level it is still starting in the content folder on the external drive. Manually browse to the cloned content folder and you should be able to open your level without problems.