Download

Level editor window is always below than the other windows. Why?

Hello. I have short question.

There are two windows, and blueprint editor window is activated. So blueprint editor window is on top.

At this condition, if I click the level editor window, then -


Level editor window is activated, but, still blueprint editor window is on top. Because of this, I can not see large part of level editor window, including PIE viewport.

Why? How can I bring level editor window to top?

I spent lot of time to search about this, in several month, with many search word. Level editor window, PIE window, viewport window, parent window… always on top, blinded by other window… (I found this here, but it does not help for me. this seems related, but I’m not sure.)

Today, finally, I spent all of day to try to modify unreal engine with source code. It was fun and beneficial for me, but I failed to solve.

This is about my productivity, convenience, and effectiveness. But also, this is about my curiosity, emotion, motivation, confidence, and desire. Because of these, it looks impossible for me to give this up.

I just want to see viewport, with playing in editor, without moving or minimizing the other window. But it looks not easy for me.

added by edit: I remembered why I choose here. In search I found these.
Why are editor sub-windows always on top, and why can’t I alt-tab between them?
How can I switch between editor windows without minimizing to taskbar?
WinExplorer: It can edit the properties of window, for example- Z Order, WS_CLIPCHILDREN. But it failed. I tried to use what I know from this through custom engine based on source code, but it failed, too.

Bumping this up, as this behavior is extremely annoying and counter-productive, *even *on a multi monitor setup.

Not sure if this will help you guys, go in editor settings and look for “Asset Editor Open Location” and select “Main Window” Then dock all tabs then arrange them as need…