Level doesn't save visibility information in scene

On os x, I save a level with visibility icon changed to hide several actors in Scene Outliner. When I reopen level, these actors are no longer hidden. I tried both Save All and Save (scene only) and neither preserved hidden/visible actors, though other changes were saved.

Hey ,

Thanks for your report! I was able to duplicate issue you described, and have created a report for it in our system.

Hi ,

I noticed same issue occurs when changing what is shown in viewport. Here are repro steps:

-open level, click show>sprites>hide all
-save level and close project
-reopen level, and sprites are visible again

, this still seems to happen that opacity does not get saved in world outliner of Unreal Editor as of 4.26. Is this being fixed?
Also we noticed that some hierarchy information gets lost on saving. Scene components under actors…


We’ve made a switch to a new bug reporting method using a more structured form. Please visit link below for more details and report issue using new Bug Submission Form. Feel free to continue to use this thread for community discussion around issue.


8 Years later… still having same issue. Visibility information is not saved in UE 5.1.

It’s not supposed to save that. eye icon in outliner is transient, session-based. If you want to hide something persistently, you should use bVisible property on actor or component class itself. Just search “Visible” in details panel.

1 Like

Hi Jared, to clarify, if I uncheck the “Visible” item in details panel, will actor still render when I render out a sequence? Previously only way I’ve found to hide an actor from rendering is by checking the “Actor Hidden in Game” box in details panel.

With regard to visibility information not being saved, when I right click on an actor and select visibility and then “hide selected at startup,” it should hide selected item at startup – when I startup project. Is that not what “hide selected at startup” means? Apparently this is a bug going back many years as there are other forums aside from this one complaining of issue.

bVisible applies to actor at all times, while bHiddenInGame only applies to runtime. If bVisible is false, I believe that should keep your actor hidden when rendering a sequence, but I don’t really work with sequencer so I don’t know.

“Hide Selected At Editor Startup” (5.2) does work! If it’s set on an actor and you restart editor and load that level, actor is hidden as expected. But this is different from temporary visibility set in outliner with eye icon.

Thanks. I can confirm after testing that unchecking “visible” does indeed hide actor from render in sequencer. Glad to hear that “hide selected at startup” works in 5.2. When will 5.2 (official not preview) be released? Any ball park idea?

Generally every 6 months, but you can get it now from github by pulling Main, that’s what I work from.