Download

Level didn't load completely again. Content "Partially Loaded"

Hello guys,

I had a threat here before where my level didn’t load at all. At this time I have another issue, with the glorious Unreal Engine’s saving mechanisms.
I have added some assets on 28/8 (3 days ago), worked on my level, but when I loaded it today, all those assets from that day are gone. Autosave, backups, nothing worked.
I frankly do not understand why Unreal editor even saves my progress, since it’s completely useless. I do not trust it anymore and every day I have stress that it doesn’t save.
But it doesn’t end here - All the .uassets are present in the project directory. All of them are there, and when I try to create a new material by the same name as before, it says

The asset ‘/Game/EM/Assets/wall_turned/wall_turned_mat’ (wall_turned_mat.uasset) failed to save.

Cancel: Stop saving all assets and return to the editor.
Retry: Attempt to save the asset again.
Continue: Skip saving this asset only.

Warning Asset ‘…/…/…/…/…/Unreal Projects/Demoo 4.9/Content/EM/Assets/wall_turned/wall_turned_mat.uasset’ cannot be saved as it has only been partially loaded

What? Why? Unreal, why? :(.
I tried deleting the uasset files, didn’t help. I tried fixing up redirectories, didn’t help. Ran it in 4.8, 4.9, didn’t help.
I have a pretty decent workstation, and I work on SSD.

Any advice?
Thanks,
Pav

Make sure to take a look at those threads, probably you will find a solution:
https://answers.unrealengine.com/questions/56362/cant-save-asset-as-unreal-only-partially-loaded-it.html
[4.7] Partially loaded asset failed to save - UE4 AnswerHub :slight_smile:

"I managed to fix my issue for the partially loaded asset.

From the test I’ve done, mine caused by the old “REINST” problem we loved so much :slight_smile:

I re-made the widget that was broken (partially loaded) completely from scratch again, using the exact same methods and variables and manually replaced the references throughout all the other blueprints. The newly created widget would save properly as long as the editor was open. The moment you would close and re-open, the SAME error occurred (partially loaded asset) on the new widget.

To fix this, I had to completely re-work how those blueprints interacted and allow it 0 possibility of cyclical dependency.

After re-working the blueprints and removing all references of the broken blueprint, delete it from your project and you should be good to go from that point onward. Once the blueprint is broken with this partially loaded bug, it doesn’t seem possible to “fix”, deleting it was the only thing that worked for me.

I expect this is the 4.7 version of “REINST” :stuck_out_tongue:

I hope this was able to at least help some people looking into this issue!"