Level Blueprint Not Running Input Action


I have a level blueprint that has an input action of TouchPinch which uses pinch on the phone and mouse wheel down.

It seems to work totally fine in other blueprint actors but in the level blueprint it doesn’t seem to want to take the call from the player.
I have it set up as receive input from player 0 which is set and then to not have the thing consume input (even if I do consume input it still doesn’t run anyway) and all the other inputtouch events are set as not to consume input.
I feel like it was working yesterday but today I opened the project and having no luck on it running.



From Kyle.

You have to enable input, before anything other than a player class can receive inputs.

Thanks for the answer Jester, this didn’t seem to work unfortunately.

All solved.
I had to check all my blueprint actors to make sure none are consuming the input and one was in a blueprint that was checked out in perforce. I then got rid of consume input and it fixed it.