Lets make Lightmass EPIC (and understandable)

Oh… hehr. Thats heavy for sure.

Nice. Will read into it. Thxs

Can anybody have source project file? Given link is expired.

Thanks this topic tutorials helps lot of lighmass.

Given Links are broken.Can you please give us a new link?

Can anybody help me what is the problem with my scene? I try a lot of things which in the topic too, but none of them solve my problem. Thanks for the help! :slight_smile:

Badly laid lightmaps and they are also too low res!!
…it doesn’t cause the artifacts but with indirect lighting quailty 1 you won’t get high quality bakes…

Thanks for the reply, and sorry, if it was a lame question… I am starting to learn UE4 two days ago.

Well done to have a bake like this after 2 days!! :wink:
…I think your walls are face snapped which is not ideal… you’ll get those dark corners + blocky artifacts… you can try just setting a higher resolution lightmap and those dark outlines should shrink/disappear…
I snap my walls at the corners so no overlapping faces…

I think the main geometry neither perfect. This is an Archicad model with a fast uvw mapping… The main goal was that I would like to test it, how things going, but I guess, it’s better to remodel it in 3ds max, and make proper unwrapping, with a good texel density. Anyway thanks for the tips again I’ll definitely take your advice! :wink: :slight_smile:

This is what is happening, it’s bug that isn’t fixed yet:

​​​​​​​

I have a big problem. When I follow all tutorials on how to achieve photorealistic architecture in unreal I don’t get it. It can’t get the soft lightning and shadows. If I have sun light pointing trough the window I got light casting on wall but not reflecting the whole room as it does in real time. Can you help to achieve photo realism.

Post a screen shot. No one can tell what issues you are facing from a simple description.

**SOLVED: I found out my mesh receiving the shadow was scaled and thus causing the bad shadows. Hope this is helpful to anyone else who makes that mistake.

Hi All,

I posted this in answer hub but thought I would try my luck here as well.

I’ve been diving deeper into baked lighting and I’m seeing very low quality shadows produced by static lights. I’ve searched the forums far and wide, I’ve tried all the usual tweaks to remedy them but I’m running out of ideas. My settings seem like they should produce higher quality shadows so I’m wondering if I’m missing something obvious or if it’s a bug.

I made a simple test level using starter and built-in engine content. I’m using 4.18.3, forward renderer on a Mac. Building at higher quality seems to have no effect on the shadow quality. Lightmap compression is off. All the meshes seem to have enough lightmap resolution. Raising it only increases the quality marginally. Raising it too high (to 2048 for the floor) seems to break the light map (it just turns into a smudgy mess).

Hopefully someone may have some ideas for anyone having the same issue as me.

Here are my lightmass settings…

Stationary light lightmap resolution and baked result…


Spotlight lightmap resolution and baked result…


Have you tried to give the light source a “source radius” larger than zero? - This looks pretty bad. Should be better. There is also a pretty visible aliasing on the geometry. I wonder if it is your video card or your general settings.

Test VLM + Sky Lighting Bounces
Use only emmisive textures (50 bounces)
VLM(5;30) + Volume fog
Spheres - moves objects

Test VLM + fog

[QUOTE=
Unreal Engine Project (4.15) for the above test scene - [Dropbox Link]
(Dropbox - File Deleted).

Will be doing some more tests soon with complex projects.
[/QUOTE]

Hello guys, anybody have this file yet?

GoogleDrive
https://docs.google.com/uc?id=0B3wYK…xport=download

Dropbox
https://www.dropbox.com/s/0ljra2l3h0…dNaji.zip?dl=0

Microsoft OneDrive

Mediafire
http://www.mediafire.com/download/9x…arshidNaji.zip

4shared
http://www.4shared.com/zip/8ARByBcice/FarshidNaji.html

Uptobox
http://uptobox.com/s6m3icy2uknu

Thanks for helping the community. Cheers.

2 Likes