Less FPS in Packaged game vs Standalone

In the same scene, in Standalone mode I have around 65 FPS, but after packaging, it decreases to 57 FPS. Is there any possible cause of this performance loss, and maybe any workaround?
Occurs both in 32 and 64 bit packaged games with Shipping build.

Maybe there is an issue in 4.9 that causes this FPS loss? Because… I suspect that this is NOT a normal behavior, right? I thought that packaged game should have equal (or even more) amount of FPS, not less.

Unfortunately I can’t check if this does happen in 4.10 until the final 4.10 will come out.

I’m getting the same issue in 4.9 / 4.10. In terms of FPS from high to low

  • Standalone -140+fps
  • Launching from my machine - 140fps
  • Shipping Build 130fps
  • Development Build 120fps
    could it be due to the compression?

Any news? Have you maybe tried it on 4.11?

On 4.11 its even worse, 160 fps+ in editor at 3440x1440 and 80fps in dev build at the same res.

Hello Slavq and Sliferblade,

I haven’t seen this issue myself but I’ll be giving it a try to see if I can see the same results. In the meantime I wanted to ask, does it only happen with your primary projects or with anything you package? Also, what platform are you packaging for?

Ive solved part of the problem, When entering fullscreen with alt+ enter while using standalone the resolution/ screen percentage doesn’t increase. However when launching from my machine i get 10-15 fps more than my Shipped build which is strange. It happens with all my projects so far, I package just for windows 64bit.

I did notice that the FPS is capped in Standalone and Packaged games but not in PIE if you have Smooth Frame Rate enabled in Edit > Project Settings > General Settings. Can you check to make sure this is disabled?

I’m pretty sure this issue has been resolved. The issue in my case anyway was that while in standalone the screenpercentage / resolution wasn’t increasing when in fullscreen resulting in a higher fps than when running pacakaged, the fps difference was so drastic for me as I have a ultrawide monitor. Anyways I do have smoothing turned off however my fps cap is set to 140, I haven’t benched marked shipped vs local yet as in 4.11 it fails to package when choosing the launch from my machine option.