Download

Lenovo AIO. UE4 blasts my GFX. Any way to reduce the power? 4-23-1

Hello. My machine has 8GB RAM and a 1650 GTX card. It is an All-in-one, so a very thin case. I loaded up a project file from the Portal… First Hour in Sequencing… and even when I set the target platform to be Mobile/Tablet and Scalable 2D/3D… my fan still went crazy fast.

Is there a way I can stop the power of Unreal? I am looking to build Half Life 1 and TF2 games as a maximum requirement.

Can you suggest, either to lower consumption… or rethink using UE4/5 and opting for another engine?

Thank you.

Are you saying that the editor is causing the fan to spin? Because the editor tries to hit the appropriate frame rate, which is unlikely to happen on your lower-end AIO computer. (Especially the RAM seems quite limited – it’s unlikely you’ll have success with only 8 GB.)

Or are you saying that the game is causing the fan to spin, when running a release mode build? If so, you may be able to limit this by setting a much lower target FPS.

In both cases, you can also reduce the load on the system by adding a sleep call inside the main world tick function somewhere (using C++.) However, this will obviously also lower the responsiveness of the editor or game, because you’re not spending all of your computer on making the editor or game run as fast as it can.

Hi jwatte.
I have only been using the editor. I can’t use C++ to limit FPS as my C++ knowledge is terrible, let alone finding out how to implement this.

It does say 8GB RAM is the recommended memory size in their FAQ. I also thought there may be a way to edit the .uproject file to stop intense graphics being loaded before I load up a project from the Portal.

You can open the console (press backtick) and type t.MaxFPS 12 to limit frame rate to 12 fps in the editor.
There’s also an ini file in the editor launch subdirectory where you can install this permanently (you may need admin privileges to change that file, I forget.)

Thanks again jwatte. I felt there was an easier option. Something in options. Yet changing project settings should change these things for me? I would of thought a Mobile/Scalable 2D 3D project running on a 2020, £1’199 PC would be a breeze for Unreal.

I think your expectations are mismatched.

As far as I can tell, it runs fine using all resources of the system, as is intended.

The specific problem here is that you don’t like the system actually using all its power. The low-end computer you purchased is designed to run the fans on high when you’re actually using it to its capacity, and games generally use a system to its capacity to get as high a frame rate as they can.

For what it’s worth, Unreal Editor on a MacBook is also quite noisy and doesn’t have top frame rates, because Apple also doesn’t provide particularly high end graphics cards in their machines, and the fans spin up as soon as you actually do real work on them.

A sigh of relief then. My machine wasn’t getting hot as such… I worried, is all. I’m still editing my Sequences project and won’t use this excuse to stop. Also as a beginner, I wouldn’t know the ins and outs. I should call this post closed. jwatte!