LeftMouseButton not being captured

Hello,

I have followed this tutorial to update my UMG interface from 4.12 to 4.14 (Quick Start To Using Widget Interaction Component in 4.13/4.14 - YouTube), and now I almost managed to partially get it working. However the Left Mouse Button event is not being triggered for some reason. I have enabled the inputs in my character, and indeed the Space Bar works.

Any idea why the LMB is not working?

Cheers,
Javi

You need to enable it.

You can do it manually within the character/level blueprint…

Or if you will be using a lot of mouse functions you may want to enable the mouse through a player controller.

That was already done, and still wasn’t working because other event was capturing the input in another blueprint. Now it works.

I am also having a problem with the gamepad controller. This is the link to the question: https://answers.unrealengine.com/questions/544311/xbox-gamepad-problem-umg-414.html

Thanks a lot for your help.

Solved by unchecking the “Consume Input” checkbox in all the blueprints that are using this event.

120938-consume.jpg