Download

Launching to device stops with no error

I tried launching my game to my Android device (Samsung G5) just to test it, and the project launcher seems to be still running but it will never finish. I thought it might be a content issue so I created a clean project and just set up some basic functionality. I tried launching that and I ran into the same problem. Then I created a new blank project, I didn’t add or change anything but I’ve still got the same problem. The build is always successful but it won’t finish the launch.

I’ve attached the log and a couple of screen grabs. This is getting rather frustrating, so any help would be great.

Thanks

CapAndroidSDK.JPGCapture.JPG

The last command (shell am start …) should have started the application running on your device then waited for you to quit. Was your device maybe locked?

The application did start on my device but… I’ve tried this three different ways now and I don’t know what the difference is supposed to be but they all behave a little differently and none seem to ever finish the process

  1. Action: Click on the down arrow next to the Launch button in the editor and select my device from the drop-down. Result: It runs for a few minutes then it doesn’t do anything more but seems to still be running. It never gives me any indication that the process is finished. It does launch on my device but if I close the application then open it again it will always hang at the splash screen.

  2. Action: Click on the down arrow next to the Launch button in the editor and select Project Launcher and select launch for my device. Result: This does basically the same thing as above but pops up the log windows, which I’m sure is whats supposed to happen. It still never indicates any finish to the process and it’s the same result on my device.

  3. Not sure if this is related or another problem but if I try to package the project the process runs for a few seconds then it says build failed and gives an unknown cook error.

Perhaps this is a stupid question but by ‘waiting to quit’ do you mean hitting cancel on the project launcher or closing the application on my device? I’ve gone through the documentation so I don’t think I’ve missed a step. Everything says that there should be a message that says the process is finished.

I’ve been working with the editor for quite a while now but this is the first time I’ve tried to launch anything. I’m probably making some nube mistake but any help you can provide would be great.

Thanks

The toast message will stay up until the process on the device is closed or you hit cancel. To find out what is going on you’ll need to look at the logcat output from the device.