Launching Bink video in packaged build

Hi,

I’m trying to get the Bink video player working.
It seems to only support loading via URL.
In editor, works fine with:
./Movies/Unseen_Intro_02.bk2
Or
B:/UnrealProjects/GIT/BoogieWoogieProto/Content/Movies/Unseen_Intro_02.bk2

Which are the relative and absolute paths to the video file.

But in a packaged build, I cannot get a relative URL to open, in fact, I have only managed to open the video with an absolute path to **the project folder video ** (not the packaged video)!

So I get the mind-boggling log as follow:

Trying to open:
…/…/…/SideEffects/Content/Movies/Unseen_Intro_02.bk2
FAILED

Trying to open:
B:/UnrealProjects/GIT/BoogieWoogieProto/Build/Tmp/WindowsNoEditor/SideEffects/Content/Movies/Unseen_Intro_02.bk2
FAILED

Trying to open:
B:/UnrealProjects/GIT/BoogieWoogieProto/Content/Movies/Unseen_Intro_02.bk2
BINK OPENED A VIDEO
Success!

Can anyone point me to what I’m doing wrong? Why can I launch the video in the Project folder, but not the one in the regular build folder?
I’ve tested putting and launching the video file from pretty much every folder of the packaged build including root without success.

Thanks!

2 Likes

Same issue here. Missing videos was not apparent on development machine, but client saw black screens.

I had some issues with this - my problem was my video files (which do not show in the unreal editor) had not been submitted to source control and were therefore not packaged with the game, which was packaged on a separate machine.
So check your .bk2 files are in the project being used to package, and it might also be worth adding your /Game/Movies directory to your ‘Additional Asset Directories to Cook’ list in your project packaging settings.