Launcher wont open

hi so I downloaded epic games launcher and and tried to open the file but all I see is a loading icon beside mouse icon then nothing happen’s I made sure that my dirvers were up to date I’m pretty sure my computer is up to spec as I have directx 12, intel quad core processor and 8gb of ddr3 ram with intel HD graphics 505 as my graphics card I tried uninstalling and reinstalling the launcher and checked other questions to see if I can find a solution but I couldn’t seem to find anything to make it launch.

Well, the launcher should open, and I’m not positive why it isn’t. It could have something to do with any anti-virus you have trying to block it from connecting to the internet. What I would do is try to open the launcher, then open the task manager (using Ctrl + Shift + Esc) and under Apps, you should see EpicGamesLauncher. If you don’t, something’s wrong. If this is the case, I’d try temporarily turning off your anti-virus. Make sure you turn it back on later If this works, close the launcher, turn your anti-virus back on, and look for something call exceptions or whitelist under your firewall. Add the launcher to that whitelist.

On a different note, the Intel HD Graphics is an integrated graphics card, and while that wouldn’t prevent the launcher from opening, it will make using UE4 difficult. You’ll have to set the Engine Scalability Settings to low if you want it to run well because integrated graphics cards are simply not up to the task of running game engines like UE4. My suggestion is to get a GTX 1050 Ti (it costs around $150). If you have any questions about the graphics card stuff, feel free to ask.

Same for me: the launcher crashes with error only in the Windows Eventviewer. With OS Windows 10 Home and the same processor / graphic card.

Event details:

Log Name:      Application
Source:        Windows Error Reporting
Date:          02/09/2018 22.08.23
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      LAPTOP-M1I9548M
Fault bucket 1462766905797750815, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: EpicGamesLauncher.exe
P3: 5b58bc2c
P4: EpicGamesLauncher.exe
P6: 5b58bc2c
P7: c0000005
P8: 0000000000002623

Detailed specs (the ones I think are useful):

Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: X540NA
BIOS: X540NA.303 (type: UEFI)
Processor: Intel(R) Pentium(R) CPU N4200 @ 1.10GHz (4 CPUs), ~1.1GHz
DirectX Version: DirectX 12
Microsoft Graphics Hybrid: Not Supported
Card name: Intel(R) HD Graphics
Device Key: Enum\PCI\VEN_8086&DEV_5A84&SUBSYS_1DE01043&REV_0B
Driver File Version: 22.20.0016.4836 (English)

As soon as I can I’ll try to upgrade Graphic card drivers

After updating graphic drivers I have the same crash (only different “fault bucket” number).
New drivers version:

Driver Version:
Build Date: August 23, 2018