Launcher won't connect to internet

When I launch UnrealEngineLauncher I receive “Error! No version info received.”
After i click “ok” i get the option to login. When i login i get the message “Error! Did not get a response. Are you connected to the internet?”
I’ve seen several pages concerning this but no one got a definitive solution.
I’ve changed the timeout time, DNS, checked firewalls, allowed UnrealEngine access, restarted my computer, and restarted my internet. (all were suggested on these forums, this didn’t fix it for most other users)

I’m not sure if this is something on my side or EpicGames’ side, but i can send a launch log if i need to.

Hi Veradux,

Thank you for your report.

We have assigned this issue to a member of our support staff, and they will begin investigation as soon as possible. If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide:

The Launcher log could be useful as well. You can find that here: C:\Users\[USERNAME]\AppData\Local\UnrealEngineLauncher\Saved\Logs

Thanks!

Hi Veradux,

You may have tried most of these already, but please look through the troubleshooting steps linked below. Afterwards if the issue is still present, follow the steps at the bottom of the page to find your ‘Verbose Logs’ and post them here. They will help us track down the issue.

Thanks,

TJ

link text

Hi Veradux,

Thanks for the log file. I see you’ve already ruled out firewall issues on your machine. Can you confirm whether or not you’re accessing the Internet through a proxy server?

Thanks,
Richard.

I’m not using a proxy server

Hi Veradux,

Please can you try opening your browser and going to https://account-public-service-prod03.ol.epicgames.com/account/api/version and let me know what you see.

Also, it would be really useful if you could open up a command prompt (Win+R, type “cmd” press enter) and run the following:

nslookup account-public-service-prod03.ol.epicgames.com

and paste a screengrab of the results. Thanks!

I am having problems with the launcher as well and tried this; this is what I got when I clicked the link:

18225-01.jpg

Also ran that command prompt and it returns “…can’t find account…” “Non existent-domain”

Not sure what any of this means really?..

{
“app” : “account”,
“moduleName” : “Epic-Account-PublicService”,
“branch” : “Release”,
“buildDate” : “2014-08-28T19:40:18.284Z”,
“serverDate” : “2014-10-17T18:16:07.660Z”,
“build” : “12”,
“cln” : “2276586”,
“version” : “1.6”
}

It looks like you might be experiencing some intermittent DNS problems Veradux. Can I ask that you try changing the DNS servers you’re using to Google’s DNS service, and see if that makes a difference?

Full instructions for doing so can be found here: Public DNS  |  Google Developers

In short, the instructions walk you through how to set your network settings to use the DNS servers 8.8.8.8 and 8.8.4.4.

Hi Jak,

My mistake. I put a dash instead of a dot in the command line to run nslookup. Can you try again please …

nslookup account-public-service-prod03.ol.epicgames.com

Sorry about that.

Also, if you could post your “Very Verbose” log files as outlined on the page https://wiki.unrealengine.com/Troubleshooting_Launcher_Problems#The_Launcher_is_unable_to_download_content that would be really helpful too.

Thanks!

I’ve done this already because of another page where someone else had the same problem. I just retried with these DNS servers and there was no change.

I’ve been trying out the Launcher’s LibCurl implementation today. Seems to work well.
I would like to ask that users here that have similar symptoms give it a go and let us know :).

Symptoms I refer to are:

To use this, the Launcher needs to be ran with the extra commandline option -HTTP=Curl you can add this to the end of the Target box in a shortcut’s properties.

EDIT: If this solution works it will usually mean the default setup doesn’t because of your internet options. I recommend having a go at fixing your settings and being able to use the launcher without any commandline, as the issue could effect other programs too.

There’s an answer for it here by Carlos Cuello: "Error: Did not get a response. Are you connected to the internet?" - Getting Started - Unreal Engine Forums

I should mention that the libcurl implementation is not yet fully QA approved :slight_smile:

DUDE!!

I can’t believe it- you fixed it!

I had tried everything:

  • reinstalling
  • removing windows+router firewall
  • switching DNS
  • disabling antivirus
  • making PC face north to appease computer gods

Absolutely nothing worked. But this, this solution fixed it!

I’m curious; what does adding this option do exactly? Why does the launcher only work for me now when this option is enabled?

You also mentioned it’s not QA approved- is there a potential issue that can come up from having this option on?

Thanks again for your help Swifty!

Awesome!

Under-the-hood the option uses a different library to perform http requests.

The default one on PC is WinINet. It suffers from problems with your internet connection settings, and the real fix would probably be to fix those, this is more proof that the WinINet implementation is what isn’t working for you. I recommend having a go at fixing your settings and being able to use the launcher without any commandline, as the issue could effect other programs too.

There’s an answer for it here by Carlos Cuello:
https://answers.unrealengine.com/questions/117925/error-did-not-get-a-response-are-you-connected-to.html

We don’t currently know of any problems with using libcurl, but worse case is connection issues still :wink:

I followed Carlos’s instructions and the launcher works like it used to last week!

I have no idea what changed those internet options on my computer, but thanks for the help!

this got me past the “Error! No version info received.” message.
however now it continuously loads the “Checking for update message”. i left it on for 6+ hours and it never left that screen.
do i need to re do all of the above troubleshooting tips? (restart internet, restart computer etc etc) or is there something else i’m missing

This worked for me, not sure what’s going wrong for you. Have you tried reinstalling the launcher again? Made sure to activate the correct internet options outlined in Carlos’s post? Carlos Post

Also have you tried adding the command line for the launcher: “-HTTP=Curl” ?

In the other thread, everyone seems to have resolved the issue with Carlos’s instructions.

i’ve done everything suggested so far