Launcher stuck on please wait

I am trying to download engine version 4.7.2. I am using Windows 7 64-bit SP1

Whenever I open the launcher, I get X.0 versions available for download (4.5.0, instead of 4.5.1, 4.7.0 instead of 4.7.2, etc). They all show the message “install” instead of “download”. Whenever I do click install, it eventually changes to the correct version (e.g. 4.7.0 changes to 4.7.2). Then, it just gets stuck on “Please wait”. Closing and reopening the launcher results in getting an “Install” message again, this time for the correct version (4.7.2). After restarting the engine, the cycle repeats.

On a sidenote, every item in the marketplace appears as purchased to me (of course, I can’t download them, they are just bugged out).

I have already tried reinstalling the launcher. I have attached the launcher logs.

Hi dissonanceint,

Thank you for posting your Debugging logs. Have you tried all of the suggestions in this section of the troubleshooting guide?

If nothing works, please post your dxdiag (system specs).

I already tried those and the problem persists.
Here is the dxdiag.

I tried installing UE4 in another PC, as well as asking a friend to install it on his, to try it on a different connection. We both got the installer stuck on “Please Wait…”
We are from Bolivia, if that helps in any way.
I’ve been using UE4 since 4.0 without any problems with the launcher.

We are having some issues with blocked IP’s in certain countries but Bolivia isn’t one of them. You should be fine there but we will continue looking into it.

It worked now, without doing anything else, both for me on both my PCs and for my friend.
You must be getting crazy traffic now that the engine is free!
Any chance this was related to traffic overload?

Yeah, it’s quite possible that the traffic we are seeing is responsible. I’m glad to hear you both got it working. If you experience anything like this again, post back here.