Launcher "sign in failed" EC-BI-LS-3

When this error comes up, all clickable links lead to “no search results found” pages.

The only thing I’ve found online is a bunch of Fortnite threads where users complain about this error as well (from mid last year), and I’m not about to edit my Windows Hosts file just to get it up and running again.

I’m currently locked out of updating the engine.

This launcher feels like a big piece of ****. The iTunes of EpicGames. Something that barely functions, nobody wants to use, yet everyone is forced to.

EDIT: When I press the little cogwheel in the bottom left corner before the login, and then select “troubleshoot”, I get 9 green circles and one red error saying “backend connectivity problem for”, and again, when I press the “fix this problem” link I get the same “no search results found” page. Sigh.

Ok, so things began to become really weird when I tried to re-download the launcher, and Firefox, Edge and Internet Explorer all told me that the download link was unsecure and had a bad certificate. I then created an exception for that which made the download link work, only it didn’t get me the launcher, rather it took me to some sort of student portal at Morgan State University (at

Rebooting both my router and the one my broad band provider supplied me with fixed these errors and got everything working, BUT:

  • Everything from Epic, including e-mail support replies were extremely unhelpful and frustrating.
  • Unreal Engine, during this time, hard crashed extremely often. It apparently phones home and doesn’t like to be denied.

I stand by my earlier comment that the Epic Launcher is a piece of ■■■■ (although the forum censoring makes it sound worse than what I’m calling it).

same thing happens to me… idk why


I have the same issue - **EC-BI-LS-3

Did you fix it in the end?**

I also can not download from website?

I found this but its still not working? I will keep digging around.

Got the same problem. It’s happening everywhere right now. It’s probably not on our side, but on epic games’ side. They better fix this fast

Ребят у меня тоже это, мне кажется или это у всех так?

Same problem here as well today: EC-BI-LS-3. I hope it will be fixed soon.

I tried to delete the whole folder for EpicGamesLauncher in user/youname/AppData/Local and surprisingly it was enough and it works. Maybe this will help someone.


It worked thanks!

It also worked for me, thanks mate!

after 2 hours trying!!! your solution worked really good thanks dude

Problem with this for me today, not sure if anyone else is affected again/still, but for me I had to sign out of all other devices through my account on a browser and was able to login. Now all my games I have not downloaded say unavailable. The help page on Epic Games shows any known issues they are trying to solve Epic Games Technical Support & Customer Service | Epic Games At the top of that page is two links with more information on the problem.