Launcher installed but will not open. msvcp120 error

I downloaded the launcher and tried to run it, but it gives me an error such as this:

39645-launcher_error.jpg

I have tried to make a logfile, to no avail, but have included my dxdiag file [link text][2]. I do have a GeForce 745m in the laptop but dxdiag doesn’t seem to recognize it, unless i am missing it.

Thank you in advance

Hi Neofuuma,

This looks like a problem with the Microsoft Visual C++ 2013 redistributables installation.

Could you try installing/reinstalling it?

I’d recommend re-installing both the x86 and x64 ones, just to be sure everything is in check for you system in general anyway.

Let us know if that helps!

installed and reinstalled both, still having the same error. Even tried the repair button on both installations.

Sorry for the late reply. I have seen issues where the redist repair options do not overwrite some files. Perhaps you can try this:

  1. Download the Win64 version of the Microsoft Visual C++ 2013 redist from here(you probably already have it): Download Visual C++ Redistributable Packages for Visual Studio 2013 from Official Microsoft Download Center
  2. Find and backup your current C:\Windows\System32\MSVCP120.dll. You can do this by renaming it to MSVCP120.dll_BACKUP
  3. Run the repair option on the redist you downloaded.
  4. If a new MSVCP120.dll was added try running the launcher. If not, restore your backed up file.

OK, i tried this method, renaming the old msvcp120, and using repair, but it seems to have put the same file back in there.
The msvcp120.dll I have shows a date of 10/4/2013 and 645kb, same as the previous file.
Launcher still fails to open, giving the same error

Sorry for the delay. This is a bit of an odd issue and I wanted to get some feed back from the people here before making any drastic suggestions. Perhaps we can collect a bit more info to help us narrow the problem.

First, Do you run any virus protection software?
Second, can you post a screenshot of the various Microsoft Visual C++ redistributables you have installed? You can find this in Control Panel under Programs and Features. It will look something like this(Note this is on my Win7 machine but Win8.1 should look similar).

No worries on the delay 0xDEADBEEF, I appreciate the time you are taking to help me resolve the issue! Yes, I run Webroot SecureAnywhere on my laptop. And here is my list of the MSVCPs in my control panel

The launcher installer installs Visual C++ redistributables for VC10, 12, and 13 using merge modules. Though I do not see any issues with the screenshot you posted I would still bet that there is some problem with the Visual C++ redistributable. I don’t know how to diagnose the problem though. In the past we have had luck tracking down odd dependency issues with tools like DependencyWalker which may provide some insight here.

Thank you again for the reply 0xDEADBEEF. downloaded and ran dependencywalker on the Launcher.exe, and have attached. Hopefully I did this correct, and it can provide some useful informationlink text

So the issue is still not obvious from the Dependency Walker image that you provided but there are some clues that might lead us to a solution. Here are the bits that look interesting:


42251-udninterestingbit1.png


42252-udninterestingbit2.png


Hi Neofuuma,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please respond to 0xDEADBEEF above.

Cheers,

TJ