Launcher installation directory/ Engine detection

Hi folks,
as noted above I have trouble with the launcher detecting the Engine.

I tried following this tutorial:
[Tutorial] Build from source with marketplace and launcher in none default path! - Marketplace - Unreal Engine Forums!

My UnrealEngine-folder is renamed to

The tut says I should (for my case) choose the directory

This creates
"C:\Users\user.NAME\Documents\GitHub\UE4\Unreal Engine"
where the launcher and dxredist reside. (I would have expected them to be in the UE4-folder)
Unfortunately the engine will not be detected.

Additionally, what I personally found confusing is that, inside the launcher folder is the same
folder structure as if it should reside in my
"C:\Users\user.NAME\Documents\GitHub\UE4\UE_4_2 -folder."

I hope I havent missed a post regarding that issue as I have found none that seem to apply to my case, although I dont think that it is a special case.
Now what should I do?

Hi MrMaster -

The tutorial you are referencing is based off of the 4.0.2 build of the engine. I am currently testing it with the latest version to see if it is still an option for you to do.

Thank You

Eric Ketchum

Hi MrMaster -

The tutorial does still work with one small addendum to get it to function correctly. Your build should be housed in a sub-directory with a name of “Unreal Engine”. So in my case, I have a directory called D:\GitHub_Release_4.2.0\Unreal Engine\

With the sub-directory of “Unreal Engine,” I was able to get the launcher installed and functional without having to automatically downloading the pre-compiled version of the engine. As a note though, the launcher will not function as it does for the pre-compiled version, but it will allow you download the marketplace items which will still save to the Documents\Unreal Projects directory. And, you will have to open them through the Editor Binary that you compiled from source and not from the Launcher itself.

Thank You -

Eric Ketchum

Hi Eric,
thank you very much for taking the time.

the launcher will not function as it
does for the pre-compiled version

If this means that it will not detect the engine but let me download the projects then this the state I have already been. I tried installing it with the appropriate
folder-name (with space), and everything felt into place but the engine will not be
detected. I can go on without that, but it makes me feel that something is
wrong every the time I open the marketplace.

again, thank you for your time.

I faced the same issue, I’m using 4.9.2 version and unable to connect Luncher to build version.
Also, I tried downloading pre-compiled version and copy/paste it in all other computers (Our studio),
First PC works normally, but others can not recognise the downloaded version located at /Epic Games/4.9
I put the same path for installing the launcher alternatively, but none of them works.

Hi Sourena,

If installing them individually isn’t’ feasible, it sounds like you would want to follow a similar setup to our academic installation.

If that doesn’t work, could you post this as a new issue in the Installation and Setup section?



Hi TJ Ballard,
I tried above tutorial too. but manifest files are in binary and unreadable, and they are no manifest file there until you install engine from launcher.
So as you said, I posted a new issue here:

Please take your time and let us know the solution.
All the best