Launcher Hangs [Windows 7] but it worked yesterday (Dec 19, 2016)

I have been playing Paragon recently in addition to working with Unreal 4.14.2

Tried to log on today a number of times but I keep getting the same result despite following tips at A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums.
(This includes closing any running processes related to the launcher and trying again)

The launcher worked perfectly yesterday and I logged on both during lunch at work and after work at home to play Paragon. Today it will not allow me to log in at home because the dialog hangs at “Please Wait.”

Here is my DxDiag file, please let me know what I can do to resolve the issue.
link text

Have you tried uninstalling and reinstalling the launcher? I have only had one similar problem in which my engine would not launch, could not get any help for it even from epic team (they say the only do things with the launcher) and I had to reinstall my OS after a month or 2 of not being able to work. To getting it running again.

Hi dodgethisunreal,

We have modified the process for how we handle Launcher issues.

Please visit:

Since you have already tried solutions from the troubleshooting guide, I suggest moving on to the contact form to get additional assistance.