Launcher fails to load, no errors. Tried everything. Please Help

As the title stats, after installing the launcher, it fails to start for some reason. I have already tried the stuff from the FAQ and read all the similar posts about this subject. So far no luck. Also updated my GFX Card driver.

Would be truely awesome if one of you guys could help me.

I have attached the DXdiag as well as the log from the launcher.

Hi yuno,

Is this your only log file? If not can you zip the whole folder of log files?

-Max B.

Thanks for the response.=)
No, but they looked pretty much the same to me.
Here are all my logs.

Any Ideas?

hmm the logs seem to stop abruptly before any telling information is shown and you DxDiag looks ok as far as I can tell. I’ll have some others take a look and see if there is something I may have looked over but in the meantime have you tried uninstall/reinstall?

Thanks. But i got the launcher to start by adding the -http=wininet to the desktop shortcut. you should definitely add that to the faq section under “The Launcher fails to load or crashes on load” too…

Now, however, I have the no version info problem. Since iam pretty sure we are not behind a proxy but do have a firewall… is there any port that has to be open?
443 TCP out?

Ah that’s the first time I’ve heard of a user crashing/not loading and having the wininet command fix them. I’ll be sure to add that to the other section as well. You’ll have to make an exception for and that should be it.

alright thanks for the help, its fixed. It was a problem with my system, nothing you could have prevented. sorry for the trouble. :frowning: i could explain it, but i doubt it would help anyone with the same problem. xD .