Launcher Error Code R-2147943860


I’m getting the above error code when trying to run the launcher. I’ve been successfully running Unreal daily for a couple weeks now and have only just now ran into the error. Nothing has changed on my machine, though as per suggestions on another related issue on the forums I’ve installed all Windows updates as I was a few days out of date. After many reboots throughout the day it still hasn’t worked.

I tried to run the command (msiexec /i C:\EpicGamesLauncherInstaller.msi /L*V C:\EpicGamesInstallerLog.txt) noted on A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums, however, I’m unable to locate the installer.msi file in order to update the path to the actual file location. Where is the typical install location for this?

Any help you have is greatly appreciated. Thank you and I look forward to hearing back from you soon!

Hi Elbryan Wyndon,

Could you please attach a screenshot of the error message you are getting?

Also, could you send your debugging logs and dxdiag? Steps on how to get that information can be found here.


Unfortunately the launcher is working now. I haven’t done anything on my end since the original post. If I see it again, I will post the requested information. I hope you guys manage to track down the issue so other users don’t experience it.

As Elbryan Wyndon’s problem seems to have resolved itself, I’ll mark this as resolved. Anyone else experiencing this issue should open up a new ticket for help.

This issue has returned. I tried opening a new ticket but it kept giving me errors when uploading a file, so I’m just going to comment here. I apologize if this isn’t the preferred workflow.

Attached are the requested files.


[link text][2]

Hi Elbryan Wyndon,

I apologize for the delayed response. When exactly are you getting this error message? Could you please copy and paste the copy and paste the target line from your Epic launcher desktop shortcut?

No problem for the delay. A co-worker told me that I can launch the project itself instead of going through the launcher. I’m embarrassed to say I hadn’t considered that. :stuck_out_tongue: Also, as a note, when I launch the project itself, it logs into the launcher successfully on it’s own. Interesting.

I get the error when directly double clicking the launcher. It goes through the Init step, then Verifying step, then Prerequisites is hit and it prompts my User Account Control. After this, prerequisites just sits on screen with the “loading” bar scrolling away. After a couple minutes I get the prompt in the image above.

Here’s my launchers command line, I had added the -debuglogging as requested, but was getting the error before that as well.

“C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win32\EpicGamesLauncher.exe” -debuglogging

Hello again,

For some reason, your target line is pointing to the Win32 directory. Once the launcher is fully installed, this should default to the Win64 directory. Can you check to see if C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win64\ exists? If it does, please verify that it contains the EpicGamesLauncher.exe file. Try running this version of the executable and let me know the results.

That worked! I’m curious how the 32-bit version got set there. However, thank you, I appreciate the help and hopefully this will help bring some info through to the devs to help ensure this doesn’t happen again, or if it does, an error code providing more information can be provided. :slight_smile:


The initial download now installs a 32-bit bootstrapper first. On first run, it download either the 32-bit or 64-bit launcher based on your system. For some reason it did not clean up the 32-bit install after downloading your 64-bit launcher. We’ll be looking into this more.

Thanks for the information and I’m glad we were able to get you back up and running.