Launcher downloaded 4.7 and now isn't showing it

I downloaded version 4.7 from the launcher. The download completed fully, but installation seems to have failed. No error was shown.

There is no 4.7 version of the engine on disk, and it doesn’t show up in the launcher - not even in the “Add New” slot.

The full 4.7 download is present in the VaultCache folder of the launcher.


I tried adding the contents of the VaultCache folder to the appropriate folder alongside 4.5 and 4.6, but this doesn’t make any difference in the launcher, or in the Switch Version utility.

I live in India, and downloading this took over 12 hours. So is there any way to get 4.7 installed without nuking everything and downloading again?

Hi ApoorvaJ,

This seems to be an issue that popped up recently, the fix would be to remove the UE_4.7 folder from VaultCache directory, and try again - making sure you see an “Install” button, not a “Download” button. I believe at the moment that seeing “Download” instead is a subtle symptom of the issue.

Like you say though, it would need re-downloading that way. I will see if I can put together some steps that you can take to avoid that.

In the meantime, if you could upload a zip of your logs folder, it may help my investigation.




You can download the logs zip here

And I really would appreciate it if you could find some workaround to downloading it all over again. Another 12 hours is just too much emotional turmoil. :slight_smile:

Many thanks, I’m trying something out now

Could you move the UE_4.7 folder out of the VaultCache, so you still have it backed up ready… But let me know if you are then able to add an engine slot, and whether you see “Install” or “Download” on it?

Ok, I think I have some steps that should help you to get 4.7 going without re-download. If you could do the test though that I mention above, by just moving the directory and letting me know what you see, that’d really help me :).

For anyone else trying this, please adjust paths accordingly for your Launcher installation location, and available drives.

Let me know how you get on! Keep a backup of the UE_4.7 vault cache folder until you successfully have the engine working in case something doesn’t go right first time :).

  1. Make sure you have no 4.7 engine versions listed in the Library, and close the Launcher
  2. Create the folder “D:\Unreal\Epic Games\4.7”
  3. Move the “D:\Unreal\Epic Games\VaultCache\UE_4.7” folder to some other location. We’ll assume “D:\UE_4.7”
  4. Copy all contents of “D:\UE_4.7\data” to “D:\Unreal\Epic Games\4.7”
  5. If structure is correct you should have Engines, FeaturePacks, Templates directories inside of 4.7 like “D:\Unreal\Epic Games\4.7\Engine”
  6. Ensure that the directory “D:\Unreal\Epic Games\VaultCache\UE_4.7” no longer exists
  7. Run the Launcher
  8. Add an engine version and make sure 4.7 is selected
  9. Ensure that the button displays “Install”. Do not click if “Download”. If it says Download, please come back with extra logs without going further.
  10. When clicking Install, you should see the engine slot transition as Please Wait… → Queued → Initializing/Installing → Verifying (with U4 logo filling) → Launch button
  11. If you see “Downloading” with a large amount of data, you may have missed some files or not got the structure correct… Or a 4.7 update was released since your problem occurred.

After removing UE_4.7, I can see the slot with Install on it.


Now trying out the further steps in your answer.

This worked perfectly! Thanks a ton @Swifty.