Launcher crash on play and save

Hi

All of a sudden, my game crashes when launched in the editor.
The last thing i have been doing from it working to now, is creating and editing a new particle system. I have deleted it, and everyting regarding it, but it still crashes upon launch. I don’t recall doing anythinbg else.
It also crashes most of the time when i try to save all the changes.

This is a copy of my most recent saved log.

link text

Hi Fjordhoj,

If you place that particle system in a new, blank project with no additional content then delete it do you have the same crash or is it limited to one project?

I have been trying to search for the error.
Apparently it doesn’t seem to have anything to do with my particle system.
I have been making a copy and deleting bits one at a time, and then checking if anything happened.

When i got to the levelBP, the editor crashes if i try to delete this node. It comes form a call event on another BP. But it dont need a game test to crash, so it’s not the activation thats wrong. If i try to delete it in any way, it crashes. Can’t figure out how t owork my way around it.

I copied and pasted the entire level to a new map, and recreated a the levelBP there, and now it works.
Is it some kind of bug? The two levelBP are the same, and the original also worked some time with the node already inserted?

Aaaaand now we’re back at it again. Has been working for 7 hrs. and now it feels like crashing when editing the same node again. I have completed the subarea in which i was working the last time it began to crash.

This is getting pretty frustrating, spending more time on searching for errors, than actually creating a game

30231-ras2-backup-2015.02.17-16.22.08.log (22.3 KB)

Where are you calling that specific node from? Is it a custom event?

Yes, it’s a custom event called from a BP set in the level

I have tried to follow the instructions on this page, as the problems seems similar.

However it still crashes upon compilation.

If you feel comfortable with it, can you send me a copy of your project? You can send it to me privately via the forums if you feel more comfortable with that. There are several known issues with Event Dispatchers that have been fixed in our latest internal build, but I’d like to test and see if the crash you are experiencing is one of these or a new crash that we are unaware of. Thank you!

The complete project should be here. You have to load map “bogo” as at is in there the error occurs.

Thank you for the help :slight_smile:

Hi Fjordhoj,

Thank you for the project. With it, I was able to reproduce this error and have entered a bug report, UE-10395 to be assessed by the development staff. As a workaround, if you delete the asset your event is referencing, you will be able to delete the event. I realize this is not ideal, however it was the only way I could get to the event and make a change without it crashing.