Launcher cannot recognise Compiled engine version

I’m using 4.9.2 version and unable to connect Launcher to my C++ build version(Github version). Also, I tried downloading pre-compiled version and copy/paste it in all other computers (Our studio), First PC works normally, because it starts with launcher and then install pre-compiled versions, but others PCs can not recognise the downloaded version located at /Epic Games/4.9.
I put the same path for installing the launcher alternatively, but none of them works.
I tried this Academic Tutorial, and it seems that it doesn’t work for new versions.
manifest files are in binary and unreadable. and as long as you didn’t download engine from launcher you can not see these files in ProgramData folder.
Even solution confirmed here, doesn’t work anymore.
During the development of UE4, many folders renamed and changed, so there is no reliable solution for new versions.
So it doesn’t matter you compiled it or copying from other PCs, Launcher can not find them.
Thanks Sourena

Hello Sourena,

I apologize for the delayed response. Could you please follow the steps here and generate the debug logs for one of the machines NOT seeing the downloaded versions? Please post them with your response.

Hi Leebowitz,
No problem,
Files you requested are here:
link text

These logs are from a PC that can’t see downloaded versions and all downloaded versions and assets are placed correctly at /Epic Games/ folder (4.9, 4.8, Launcher etc…)

Hi Sourena,

Thank you for the information. Your issue is currently being investigated. Could you please follow the steps I posted above to generate your DEBUG logs? They are more verbose and should contain more information for us.

Hi Sourena,

Have you been able to produce the debug logs? If so, please attach them here so we can continue our investigation.


Hi Eric,
Thanks for your follow up.
Actually, I already attached them to my last comment. at this time “Oct 22 '15 at 12:31 AM”
Please take a look and let me know if it’s OK, otherwise I can generate new one.

Hi Sourena,

The logs that I see attached above are the normal logs generated by the launcher. In order to create debug logs, you need to enable them in the launcher. The debug logs are more verbose and contain more information for us to review.

Hi Eric.
Here is the whole files in logs folder in debug mode.
Please let me know if you need any thing else.

link text


Thank you for the files. They have been added to your ticket for investigation.

Hi Sourena,

Again, I apologize for the delay, but we’ve been going over your issues.

First, the launcher does not support the gihub build of the engine. It won’t show up or be listed among the other pre-compiled versions.

Second, to move a engine between systems you need to move (in this case) the “C:\Program Files\Epic Games\4.9” folder and the corresponding manifest file from the original computer. As of right now, these can be found under “C:\ProgramData\Epic\EpicGamesLauncher\Data”. Be sure to maintain the same file structure that is shown on the original machine.

The launcher is designed to run, detect the installed manifest, and create an engine slot for the installed engine.

Please try this or, if you have already done this, reply back and let me know the results.

Hi Sourena,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

Hi Eric,
Sorry for the dealy, I was on vacation.
I tried it and it works properly.
This part is very important:“Be sure to maintain the same file structure that is shown on the original machine.”
Otherwise, it just shows installed versions and won’t work.
Thanks eric