[Launcher] 4.7.1 stuck at verifying (29%)

Everything goes fine for the verification until 29%. Then everything slows down. My whole computer. I have to pause it or to close the launcher. I tried waiting for a long time but it just doesn’t make any progress after that point.

I don’t think my computer is too slow for the verification, I have quite a decent pc and when I check my RAM/CPU usage, it’s not even going crazy. So it kinda looks like a massive hard-drive usage? I don’t know.

I checked the page about launcher troubleshooting and nothing helped. I tried looking for other topic but saw nothing similar. I’m installing it on the E:/ drive. Some would advise to install it on C:/ but I’d rather keep that as a last call, since 1) I have a bad connection and don’t want to redownload it if avoidable 2) I use C: only for my OS.

Running the launcher as administrator with my AV turned-off.

Thanks for your time.

I found this repeating a few times near the end of my Epic Games Launcher log, if it can help:

[2015.03.04-02.23.00:516][  0]LogFileManager:Warning: ReadFile failed: Count=0 Length=4194304 Error=Data error (cyclic redundancy check). for file E:/Epic Games/4.7/Engine/Binaries/Win64/UE4Editor-Engine.pdb
[2015.03.04-02.23.00:517][  0]BuildDataGenerator: Verify failed on UE4Editor-Engine.pdb

Looks like there is a corruption in downloading the file. I am afraid but your best bet is to re-download it.

Aw. But, isn’t the point of file verification to you know… Warn you of that kind of thing?

So as Anshui said, redownloading the file fixed it. Thanks for your time, problem solved!