Launch on android fails after build complete

Hi all.
I’m using UE 4.16.3 and trying to launch our project on Samsung Galaxy S4.
The log shows the build is complete but when I try to open the app, it gets terminated after a few seconds; i.e. it never gets past splash screen.

I tried reinstalling Codeworks and Unreal Engine.

Also tried removing ‘Binaries’, ‘Saved’, ‘Intermediate’ folder from the project folder.

So far nothing worked.

Hope someone could point out what I’m doing wrong.


link text

Have you tried just creating a blank project in 4.16.3, building to Android and trying to run it?
This may give you some more specific errors if it does not work.

I had this happen to me before and after a clean install of Codeworks and all the relevant parts I could build to Android and run apps again (newly made ones)…

Try to package it as Shipping instead of Development and check if you got the same problem. That might be some content missing.

Actually I already tried that. Shipping fails too :confused: Could you elaborate? Which case would be deemed as ‘content missing’?

Well, a clean project doesn’t work either. And as I mentioned before I already tried reinstalling engine and codeworks… Maybe what I did was not clean install. I had no idea what I should do to properly remove the entire codeworks-related files so I just manually erased the folders(NVPACK and NVidia) and reinstalled. Care to explain the exact process you tried?