Launch Character Bug

My setup is that I have a Character blueprint called Enemy. I made a new blueprint with Enemy as the parent. When I try to use the Launch Character node with this new blueprint as the target, nothing happens.

I tried another setup where I just used Enemy as the target, rather than the blueprint based off of it. Launch Character works perfectly.

I think that Launch Character is expecting the parent class to be character. If it has a different parent, it does not work, even if that parent’s parent is Character.

Maybe this is working as intended but I was annoyed that it didn’t work the way I thought it would.

Hey ,

Could you please provide me the exact reproduction steps to replicate the issue you’re experiencing? Could you also tell me whether or not you’re on 4.8.0 or 4.8.1? Did you obtain the editor from GitHub or the Epic Games Launcher?

Looking forward to hearing back from you! :slight_smile:

I did a workaround but after testing again so I could reproduce for you, everything works fine. Maybe a computer restart (not just an editor restart) fixed everything because this definitely did not work yesterday.

I’m glad that everything is working at this time. Please let us know if anything else seems strange with the editor and we’ll assist you further.

Have a great day! :slight_smile:

I am having the same problem, but restarting my computer still doesn’t fix it.


Which version of the engine are you working in? Could you please provide me with some additional details regarding the trouble that you’re having with your character blueprint?

Looking forward to hearing back from you, thanks!