Laucher can't connect to internet

I followed [this][1] guide but still can’t get launcher to connect. So [here’s][2] the log file.

Here’s what i’ve tried:

Disabled Firewall and spyware.
Use TLS 1.x option enabled.
Tried -HTTP=Curl.
No proxy.
Changed to google dns.

Going to gives me:

“app” : “account”,
“moduleName” : “Epic-Account-PublicService”,
“branch” : “Release”,
“buildDate” : “2014-12-03T20:32:18.400Z”,
“serverDate” : “2015-01-09T14:40:20.707Z”,
“build” : “39”,
“cln” : “2375174”,
“overridePropertiesVersion” : “$Revision: #43 $”,
“version” : “1.10”

Nslookup gives me:


I came across this problem after i installed 4.7 and could not open any earlier projects (from 4.4) so i thought
to revert engine version but now a laucher problem occured and can’t install any versions.

So, no usable engine installed right now. What is yet to be tried?

Hi Dave,

Thanks for posting all that info to let us look into your issue, really useful.

I’ve taken a look at your log file, and it looks like the problem is the launcher is not successfully validating the SSL certificate on our back end services. Looks like the problem is that the clock on your PC is wrong, the log file indicates your local time as 02/09/14.

Please can you ensure that your system clock is set correctly and try again?


Wov! Solved at speed. Thank you very much.
I guess date and time settings got mixed up when i took apart and reassembled my components few days ago.