Download

Last frame of animation in sequencer is 0.1 frame long instead of 1 whole frame

Hi

I have a problem with all my animation in the Sequencer.
The last frame of all my animation in the Sequencer is 0.1 frames long instead of 1 whole frame, which makes a gap with the default position between the next animation inserted in the sequencer.

In Maya I export 35 frames animation from frame 1-35.

Then inside Unreal it displays as frame 0-34, still 35 as it should be.

But in the Sequencer the last frame is only a tiny part of the whole frame when you zoom really close.


frame 34 zoomed in

That means if I insert another animation behind it then there is a small gab with the first of frame 34 with no animation so the character jumps to the default position in a split second.
Does anyone know why the sequencer doesn’t make the end frame last a whole frame of time?

  • Rasmus Moller

maybe your maya export isn’t the same fps as unreals?
you could always export more frames, then just trim what you don’t need

there’s also settings on the animation track to keep it’s position rather than jump to the start

YuuJin thank you for answering :slight_smile:

The framerate is 24 in both Maya and Unreal, and it does the same if I export a 2 frame clip or a 100, so I don’t think it is the framerate. Then it would be more offset.

And yeah, right now I just told my animator team to export one extra frame and then I’m trimming it, but our pipeline is set up so all shots are separate animation files. So I have to do this with a lot of shots and was wondering if it was possible to find out why it is not treating the last frame as a whole frame.

I’m not sure I understand what you mean by the animation keeping its position rather than jump to the start.

if you set the when finished> keep state
it’ll just retain it’s last frame

you can probably look into python for automation your imports

Ahh “keep state”.
It works perfectly, thank you so much :smiley: