Laser + Photos Reconstruction Problem



I’m having issues with the reconstruction of a dataset that contains photos and scans from a Leica BLK360.

I registered the scans on Recap Pro and imported the E57 with exact setting (importing in Draft results in several components).

This is what the laser component looks like.

After adding photos and aligning with control points I get this:

Then the reconstruction on preview seems to give these promising results:

But after reconstruction on Medium the end result is this:

I was wondering if this issue might be related to the one on this thread

, but then I guess that wouldn’t explain why Preview reconstruction seems to work.


Any help would be appreciated.


I’ve tracked the issue and it seems to be connected with the minimal distance between points setting. What happens is that I need to set that to 2cm or higher in order for the entire laser component to reconstruct. However, if I reduce the the reconstruction box  to a portion of the model I can go as low as 3mm. This, of course, creates very different results, as you can see here:

complete model with 2cm minimal sampling distance:

small region with 3mm minimal sampling distance (laser only, photos were disabled):

So I’m not sure what’s happening here. Shouldn’t the minimal sampling distance be an absolute value for the entire project? Is it dependent on the size of the reconstruction region?


Hi Cabral,

I’d say it’s the same phenomenon as in the post you’ve linked! My first impulse was to link it to you, only to see that you’ve done it already…  :wink:

Anyway, I don’t really have an idea what might be the case because in the other thread, it seems like the alignment of the images to the scan doesn’t work, they are in different components. Does the same happen to you?

Hi Gotz!


Thanks for your feedback again! By now I must have read a hundred of your helpful posts during the past months!

Following the instructions from the RC video tutorial I have a component just for the lasers and another component with lasers and photos aligned (about 40 scan locations and 1400 images). And I’ve been testing these parameters on both independently.

And now I’ve just confirmed that the minimal sampling distance depends on the size of the region. I just reduced it a little more and now I could do 2 mm. Is this a bug or is it supposed to work like this? Doesn’t make much sense to me.