Download

lanscape importing issue- spikes

hello community.
i have started working on the landscape in my game.
i made a nice looking lanscape in geocontrol 2.
when i import the landscape, and i still have not click the ‘import’ button, the green lines are not looking like my landscape. they do look fine though.
but the real issue is whehn i click ‘import’. the result is just very tall spikes that has nothing to do with my landscape.
anyone knows why this is happening?

Do you mind showing us some images so we can better address you’re problem?

Hi Hrsidkpi,

As Crash suggested, can you post some pictures or a test asset that you can recreate the issue with to provide?

I’ve seen users have landscape “spikes.” This was directly related to the landscape material that was created and the user having tessellation enabled. If you’ve got a material applied with tessellation make sure to turn that off to prevent the spikes.

Tim

i dont have any materail applied in ue4, should i?
and i also dont know what a tessellation is.

about the pictures, here you go:
in geocontrol2- http://s9.postimg.org/6ame28ikf/landscape_in_geo.png
in ue4- http://s29.postimg.org/uqk59x4vr/landscape_in_ue4_before_import.png
in ue4 after import- http://s9.postimg.org/gtqz55am7/landscape_in_ue4_after_import.png

Hi Hrsidkpi,

When you import the heightmap make sure to adjust the Z scaling to a lower number. This will give you much better results. Do not pay attention to the wireframe shape per se. It is a basic rendering. When you click the Import option at the bottom it will add the remaining detail but the z axis scale is where you’ll get rid of the landscape spikes like that.

LandscapeSize.JPG

If you are still having issues please upload your heightmap or a test one and I will make some steps to follow for better results.

Thank you!

Tim

tried that already.
i still get spikes, its just they are lower. but so do the normal landscape so its actualy the same result.
here is the download link to the heght map- http://speedy.sh/w4YG6/test1.raw its is a test one.

Ok, so I think I got it figured out for you.

This isn’t a bug or anything that I’ve previously mentioned but rather just the way the raw is handled.

As soon as I opened the .raw file it was apparent that the spikes were caused by the heightmap and nothing else.

Heightmaps are made based on a 0 to 1 (black to white) color, similarly to the way we use metallic and roughness in the material editor. Anything in between gets a value between 0 and 1.

The image is appears to be a lot of 0 and 1 values with some in between values but mostly skewing harshly to one or the other. This is what is causing the spikes.

To illustrate this more clearly I’ve taken the original .raw file and brought it into photoshop and added a gaussian blur to the image to smooth out this issue.

For comparison the below images are the imported heightmaps.

This is the original heightmap, and as you can see where I was point out earlier about the 0 and 1 values you can see a lot of components that are stretched above and below the mid-line. This is the result of the image file.

c99a97610f2af6a03b3a3cea2bad199f215a67ff.jpeg

In this one you’ll see where the gaussian blur has changed those harsh 0 and 1 values into a value in between that has smoothed out the spikes.

I hope this helps explain what was going on a little better.

If you have any questions feel free to ask. I’ve not used Geocontrol 2 before so I’m not sure with anything related to that.

The heightmap image above with the blur added is the one that I imported in for the heightmap if you need to compare this (I also changed the scale on import for the z. Instead of having it at a low number I pumped it back up to 100 to get the result above).

Tim

thanks you, i tried to mess up with the settings to make this as you said.
turns out i needed a 16 bit raw and not 32 as i used.
thanks alot.

Ah, that’ll do it to! Didn’t catch that before.

Glad you’ve got it working now! :slight_smile:

Tim