Landscape visibility tool breaks physical material detection for traces

I’m using the landscape visibility tool to cut a hole in the landscape (to create caves etc).

It works great, however… Once you cut a hole, the rest of that landscape component then fails to return the physical material when doing traces against it. This means my system for detecting footsteps becomes broken.

Any ideas on how to fix this (or a work-around)??


I’m pretty sure this is because the visibility tool adds a new layer to the material (a mask) which trumps all other layers. So when trying derive the physical material from a trace, it’s always hitting the mask layer rather than anything else.

I was thinking one workaround for this (to allow for cave entrances) is to have some kind of cave entrance that has the player turn a corner (so they can’t see any of the landscape), then disable the landscape visibility and set the player to not collide with the landscape. Anyone know what collision settings would b required for this?

Can you add doors to the cave or make entirely above-ground mesh that represents a cave entrance? You could load caves like the way Skyrim does it. Or do you want completely seamless level streaming?

If you’re going with the workaround to disable landscape visibility and collision, I would suggest placing the landscape in a separate level and then unloading it when you get to the cave. If that’s not an option, I might suggest a Kismet node to change collision and visibility on the landscape. SetCollisionType(COLLIDE_NoCollision) and SetHidden(true).

Thanks for the reply @Nathaniel3W . The level needs to be permanently loaded as it is an open world game where the host can be a player (listen host), so I’m not able to just disable collision on the landscape as other players would fall through the floor. I need to somehow disable collision on a specific player pawn (most likely when entering a volume).

Any ideas?

Sounds to me like this is something that should be doable with collision channels… But I’ve never gotten those to work the way I wanted. And you would have to recreate just about everything that happens with PHYS_Walking if you wanted to toggle collision channels on your player.

How about this instead?

Keep the entrance to the cave above ground, and put the underground section of the cave somewhere well below the landscape. Put in some trigger volumes to teleport the player from the landscape to the cave and back again. You could fake being able to see into and out of the cave with some camera actors and render textures. You could also mess with the post-process effects to hide any discontinuities, making the world too bright or too dark for a couple of seconds while the player’s eyes adjust to the light.

as far as I know there is no way to make Landscape stop colliding with Pawns (because it’s blocking collision) but I might be wrong
sadly I don’t have any workaround ideas either