Landscape Visibility Mask not working with RVT?

Hey guys, the Landscape Visibility Mask function (Visibility button under the Sculpt tab) doesn’t seem to work with RuntimeVirtualTexture on my terrain, which is a bummer since it’s the only way I know to create holes in the terrain.

Anyone know of a fix, or possible workaround for this?

Thank you,

This works, and produces a hole in the landscape

RVT setups (including the one we use) often have several mask pins - but it should be the one with a route to the output where the landscape visibility node is corrected.

It may be possible to store mask data in a RVT too, but not totally sure about that.

I had this issue too and totally couldn’t get my head around it, not with using a landscape layer blend material with RVT, just too many areas where it could go wrong, (I ended up breaking my RVT trying).

I was getting the following message under visibility in Landscape mode -

"Note: There are some areas where visibility painting is disabled because Component/Proxy don’t have a “Landscape Visibility Mask” node in their material. "

All of my layer blend materials had the node connected to opacity mask so the only thing I could think of which could be causing it was the RVT. It was working before setting up RVT.

I looked at the image above but couldn’t figure out where this is set up in the materials and what else needs to be done i.e. do you need to set up the visibility mask node in the object materials also? and what settings do you choose in the RVT asset to get the correct pins (more info on that would be helpful) so I found a work around which could help others too.

I just added a landscape blend layer that was transparent (opacity mask having a value of ‘0’) and painted that on instead of using the landscape visibility tool, works exactly the same.

I actually just swapped the visibility mask node to a scaler set to ‘0’ on an existing material layer I’d already set up that had textures going into it - I think this might be important for the blending of layers to work correctly i.e. you need all of the same inputs on each blend layer - I may be wrong but I’ve had issues with specular before where one blend layer didn’t have a specular input, so it might pay to use some place holder texture on the blend layer that you want to be transparent if you run into issues with landscape segments looking off color where the transparency is painted.