Download

Landscape tiles broken on Mac that work on PC

Hi, I have a scene I have been working on a pc using landscape for my terrain instead of a static mesh. Everything seems to work fine there. When I transfer it to my mac I get tiles that won’t build. I can transfer to other PC’s with no problem. This happens on my Macbook Pro and Mac Desktop. (where I have my launch to Ipad setup (can’t get it to go on a pc yet…))
I’ve tried re-creating the scene just on the mac and the tiles start breaking after I paint for a while.
I do have a few paint layers set up. I’ve seen in other posts mention of a limitation on paint leyers per tile. (6?) It’s just odd that I can get many layers working on one and not another. Is there a different limitation on OSX vs windows?
It would be difficult to try and do a golf course without several layers…

My textures are all set as shared wrap.
Using 3 custom uv channels for different scaled textures.
I’ve tried setting different textures as Alpha blend instead of weight blend.
I’m on 4.7.6.
Any help would be appreciated.

You have far too many texture samplers for OS X which is limited to 16 by Apple’s OpenGL implementation - I don’t expect this limit to change. The material editor should be showing you the number of samplers being used and whether that is acceptable for the current platform, which on Windows will be fine, but when you come to deploy on a Mac the material won’t compile. Reduce the number of different textures & samplers you are using the shader, there should be a switch node that lets you turn on more textures & samplers for Shader Model 5 (i.e Windows D3D11) and off for Shader Model 4 (as used by Mac OpenGL).