Download

Landscape static mesh proxy (LOD) generation and RVT

Actually when using an RVT material on landscape, the LOD generation tool (world composition landscape) is using RVT to generate texture maps for each LOD instead of the actual material, resulting in extra low mipmaps textures for LODs.
The only solution I’ve found is to add a static bool switch in the landscape material to turn off RVT before generating LODs and turn it on back when done. Obviously it means recompiling every shader after each operation (and there can be a lot while you alternate play test and landscape modifications).

We’ve passed this along to the team, Haoris. Thank you!

Thanks. If someone can check the problem with proxy LODs textures having white lines on borders, it would be nice as it’s related to the same process.
Image of how borders of proxy LODs textures looks like (what you see is the junction of two LOD tiles) :