Download

Landscape Shadow Problem

Hello,

long story short. This 2 Pictures are 2 different Projects. Created on different Version of UE4. Since i tried out first time the Landscape tool, i got shadows like this.


I checked out World Settings, Landscape Light Resolution (not really a fix), all meshes have lightmaps (tried out different resolutions), there is also a Lightmass Importance Volume, …
and so on. Iam done with my knowledge. I tested all my meshes in UDK and had no Problems. Whats the problem with the landscape and my setup?
I check all the setups of the Foliage i used, but also no different results. The Static Meshes, have the same Problem, but not so disgusting. like the trees and the gras.

would be great, if someone could help. Used the Search-Tool, but execpt the thread about Lightmap Resolution for Landscape, i found nothing.

greetz

Hi Spaehling,

All you need to do is select your Landscape component and in the details panel you’ll want to adjust the lightmap resolution to a higher value. The default is 1. Adjust it up in single digits until you get the resolution you like. Start with 2, 3, 4 and see if this helps before going higher. Don’t go too high as this will greatly increase your light build times. Also make sure you haev a lightmass importance volume around your landscape.

Thank you!

Tim

a2a3d2b60af6e80334910650b785df2d851e196d.jpeg

hey i tried this out, and this did not helped. I only got way longer build times. i tried out 2, 4, 8

Correct me if iam wrong ^^

Edit:
i checked out Content Creation and the Landscape Demo. They also have Landscape Light Resolution on 1 and got nice shadows.

Edit 2: added screenshot of the landspace demo.

I don’t know if you tried this already, but if you set your directional light to moveable and enable cascade shadow maps then up close your tree shadows will look much crisper. This does impact performance though.

well i turned now the directional light to movable and turned on “cast dynamic shadows” for the foliage. That makes the shadows better.
I forgot to turn on alpha on the Envoirment Color in World Settings. In Combination of both, the shadows looks fine now. But the Movable and Dynamic Shadows are not really the normal waf of how to or?

edit: ähm could i maybe have to do something with texture streaming? and the shadows get turning down automatic?

Yesterday fighter5347 and i tried out to find out whats wrong. We shared Assets each other and tested the Light Build. He get some different results like me.
There should be some more possibilities why my Landscape makes this strange shadows. Maybe its something really dump, but it turns me crazy -.-.

I will try out some more stuff to check if I’m somehow abel to recreate your problem :slight_smile:

hey did we got any news?

cause yesterday i fight again with landscape, lights, lightmass importance volume and so on. Shadows are still ultimate ugly. Turning the Light into moveable isn’t the way i want it.
I want to have baked static Light with normal shadows, like in the good old UE3 Times.

The Shadow Problem is on Static Meshes and Foliage Meshes. Maybe it hasn’t something to do with the landscape, maybe we need to search somewhere else.
Cause the shdows from Static Mesh to Static Mesh looks also really ugly.

I saw iam not allone with this Problem. But i dont saw any fix for the others. :frowning:

Edit:
okay i tried servals things out. it looks like the Landscape has nothing to do with the Problem. cause i loaded an example level and the shadows looks like the same.
Thx chimp for his help.

bug_10.jpg