Download

Landscape Realtime Lighting Issues [HELP]

I have been doing some archviz and interior lighting for UE4 for some time now and am trying to go bigger by trying out landscapes.
So I created a landscape in WroldCreator 2 and imported it into UE4. But for some reason realtime shadows are not working on my landscape, even though “ForceNoPrecomputedLighting” is turned on.
If I brighten up my directional light, it lights up everything in my scene even behind mountains.

Right now I deleted all of my lights and dropped in a realtime directional light, but now my entire scene is black, even after baking…

Can someone help me with what I am doing wrong?

Upon further investigation, it seems like only my skylight has affect on the scene…

For the directional light, increase Intensity to at least 10,000 lux. Enable Distance Field Shadows, and increase Distance to 100,000. If 10,000 Intensity is too bright, reduce it by half per iteration. Decrease "Volumetric Scattering Intensity too before doing those other changes. There’s also an option in Project Settings called “Generate real-time landscape GI data” to enable with distance field shadows.

Hm… I did your changes but to no effect. I’ve come to notice that my shadows only get drawn within a 5-10m radius around the camera. Even though the shadow cascade distance is set to 600.000.
The weird thing is, that I redid my entire scene in a new scene with a new lanscape and everything was fine. But now that I moved my project to a different desktop, my shadow distance is broken… I’ve already verified my 4.25.3 installation, so i don’t think it’s that?

Do you have any other suggestions?

Here’s a screenshot btw:

OMG I just found out the problem/solution… turns out I had my engine scalability set to cinematic, when I switched it back to EPIC the shadows were fixed:

That was an easier fix than potentially doing a bunch more adjusting. I was suggesting those settings to see what the effect was, in order to get a better perspective of the problem and where it was coming from. It looks ok now.

Yes i’m quite happy with the results.
Only problem now is that because it’s real time lighting the GPU is taking up a massive hit according to the profiler.
So next up is getting it static and improving the performance!